aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/python-pyfakefs-remove-bad-test.patch
diff options
context:
space:
mode:
authorChris Marusich <cmmarusich@gmail.com>2019-04-18 00:40:21 -0700
committerChris Marusich <cmmarusich@gmail.com>2019-04-24 21:08:36 -0700
commit968e86bd930936d9f9ed0db299164018882cd5c1 (patch)
tree8dbc6946f7d055cf1b7c58d4cab25856f721465b /gnu/packages/patches/python-pyfakefs-remove-bad-test.patch
parent0406434baaf180af51c02c2cee02d972356047b3 (diff)
downloadguix-968e86bd930936d9f9ed0db299164018882cd5c1.tar
guix-968e86bd930936d9f9ed0db299164018882cd5c1.tar.gz
gnu: Add python-pyfakefs and python2-pyfakefs.
* gnu/packages/patches/python-pyfakefs-remove-bad-test.patch: New file. * gnu/local.mk (dist_patch_DATA): Add the patch. * gnu/packages/check.scm (python-pyfakefs, python2-pyfakefs): New variables.
Diffstat (limited to 'gnu/packages/patches/python-pyfakefs-remove-bad-test.patch')
-rw-r--r--gnu/packages/patches/python-pyfakefs-remove-bad-test.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/patches/python-pyfakefs-remove-bad-test.patch b/gnu/packages/patches/python-pyfakefs-remove-bad-test.patch
new file mode 100644
index 0000000000..a9488bbe43
--- /dev/null
+++ b/gnu/packages/patches/python-pyfakefs-remove-bad-test.patch
@@ -0,0 +1,23 @@
+This test incorrectly assumes that the root user is always available.
+However, in the build environment, the root user is not available.
+Note that because the original file distributed in the release on PyPi
+has lines ending in CRLF, those are retained in the diff below.
+
+--- a/pyfakefs/tests/fake_filesystem_test.py 1969-12-31 16:00:00.000000000 -0800
++++ b/pyfakefs/tests/fake_filesystem_test.py 1969-12-31 16:00:00.000000000 -0800
+@@ -1021,15 +1021,6 @@
+ self.assertEqual(self.path.expanduser('~'),
+ self.os.environ['HOME'].replace('/', '!'))
+
+- @unittest.skipIf(TestCase.is_windows or TestCase.is_cygwin,
+- 'only tested on unix systems')
+- def test_expand_root(self):
+- if sys.platform == 'darwin':
+- roothome = '!var!root'
+- else:
+- roothome = '!root'
+- self.assertEqual(self.path.expanduser('~root'), roothome)
+-
+ def test_getsize_path_nonexistent(self):
+ file_path = 'foo!bar!baz'
+ self.assertRaises(os.error, self.path.getsize, file_path)