aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/pyqt-unbundled-qt.patch
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-10-20 16:34:15 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-10-21 00:34:02 +0200
commite8062974d5cc598134da4d57ff45970ac431611b (patch)
tree8e30cae075f4df61b7f6a2583408c1cbf5154c48 /gnu/packages/patches/pyqt-unbundled-qt.patch
parent023522d3a1e81fe9bc803183337fdc8c183a88c4 (diff)
downloadguix-e8062974d5cc598134da4d57ff45970ac431611b.tar
guix-e8062974d5cc598134da4d57ff45970ac431611b.tar.gz
gnu: python-pyqt: Fix runtime error.
* gnu/packages/patches/pyqt-unbundled-qt.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/qt.scm (python-pyqt)[source](patches): Add it.
Diffstat (limited to 'gnu/packages/patches/pyqt-unbundled-qt.patch')
-rw-r--r--gnu/packages/patches/pyqt-unbundled-qt.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/patches/pyqt-unbundled-qt.patch b/gnu/packages/patches/pyqt-unbundled-qt.patch
new file mode 100644
index 0000000000..5c91ed031c
--- /dev/null
+++ b/gnu/packages/patches/pyqt-unbundled-qt.patch
@@ -0,0 +1,19 @@
+Remove test for bundled Qt which breaks dependent applications. This has
+been fixed in 5.13.
+
+Taken from Arch Linux:
+https://git.archlinux.org/svntogit/packages.git/tree/trunk/python2-pyqt5-crash-fix.patch?h=packages/pyqt5&id=3e56e11d1fd7b1eac8242ce64c58db2bd9acba20
+
+diff -ur PyQt5_gpl-5.12.3/qpy/QtCore/qpycore_post_init.cpp.in PyQt5_gpl-5.12.3b/qpy/QtCore/qpycore_post_init.cpp.in
+--- PyQt5_gpl-5.12.3/qpy/QtCore/qpycore_post_init.cpp.in 2019-06-25 14:41:02.000000000 +0200
++++ PyQt5_gpl-5.12.3b/qpy/QtCore/qpycore_post_init.cpp.in 2019-07-01 17:06:34.882644535 +0200
+@@ -151,8 +151,4 @@
+ // initialised first (at least for Windows) and this is the only way to
+ // guarantee things are done in the right order.
+ PyQtSlotProxy::mutex = new QMutex(QMutex::Recursive);
+-
+- // Load the embedded qt.conf file if there is a bundled copy of Qt.
+- if (!qpycore_qt_conf())
+- Py_FatalError("PyQt5.QtCore: Unable to embed qt.conf");
+ }
+