aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/openblas-fix-tests-i686.patch
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-07-13 00:25:45 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-07-13 00:25:45 +0200
commit49b6dc2b4e02269850dacc71d9e7ec93139ec5b5 (patch)
tree75c62cc7620a7602a37067dd01268393aec32698 /gnu/packages/patches/openblas-fix-tests-i686.patch
parent7519dc95c7628ceeb5ed616604e8c432723a0a50 (diff)
parent2776b5d5bf3514717cf224de34c0bf2d894f1cee (diff)
downloadguix-49b6dc2b4e02269850dacc71d9e7ec93139ec5b5.tar
guix-49b6dc2b4e02269850dacc71d9e7ec93139ec5b5.tar.gz
Merge branch 'staging'
Diffstat (limited to 'gnu/packages/patches/openblas-fix-tests-i686.patch')
-rw-r--r--gnu/packages/patches/openblas-fix-tests-i686.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/patches/openblas-fix-tests-i686.patch b/gnu/packages/patches/openblas-fix-tests-i686.patch
new file mode 100644
index 0000000000..3325546ea3
--- /dev/null
+++ b/gnu/packages/patches/openblas-fix-tests-i686.patch
@@ -0,0 +1,35 @@
+Fix a test failure on some i686 systems:
+
+https://github.com/xianyi/OpenBLAS/issues/1575
+
+This patch is a squashed version of these commits:
+
+https://github.com/xianyi/OpenBLAS/pull/1583
+
+diff --git a/kernel/x86/KERNEL.NEHALEM b/kernel/x86/KERNEL.NEHALEM
+index 835520ef..65b03ae5 100644
+--- a/kernel/x86/KERNEL.NEHALEM
++++ b/kernel/x86/KERNEL.NEHALEM
+@@ -1,3 +1 @@
+ include $(KERNELDIR)/KERNEL.PENRYN
+-SSWAPKERNEL = ../arm/swap.c
+-DSWAPKERNEL = ../arm/swap.c
+diff --git a/kernel/x86/swap.S b/kernel/x86/swap.S
+index 54b00b33..e30c2789 100644
+--- a/kernel/x86/swap.S
++++ b/kernel/x86/swap.S
+@@ -138,6 +138,14 @@
+ /* INCX != 1 or INCY != 1 */
+
+ .L14:
++ cmpl $0, %ebx
++ jne .L141
++ cmpl $0, %ecx
++ jne .L141
++/* INCX == 0 and INCY == 0 */
++ jmp .L27
++
++.L141:
+ movl %edx, %eax
+ sarl $2, %eax
+ jle .L28