aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/icecat-CVE-2015-2733-pt2.patch
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-07-04 05:22:49 -0400
committerMark H Weaver <mhw@netris.org>2015-07-04 05:44:10 -0400
commit4463c0d2161f66c4ff0d52c50ff0a3a030686f1b (patch)
tree3f1aba42fd040420a2ee6964d6a5ec134adeb8be /gnu/packages/patches/icecat-CVE-2015-2733-pt2.patch
parent4cd86f5d52d6faac6668dc9853a5e5ecc9236ba9 (diff)
downloadguix-4463c0d2161f66c4ff0d52c50ff0a3a030686f1b.tar
guix-4463c0d2161f66c4ff0d52c50ff0a3a030686f1b.tar.gz
gnu: icecat: Fix CVE-2015-{2722,2724,2728,2733,2735,2736,2738,2739,2740,2743}.
* gnu/packages/patches/icecat-CVE-2015-2722-pt1.patch, gnu/packages/patches/icecat-CVE-2015-2722-pt2.patch, gnu/packages/patches/icecat-CVE-2015-2724-pt1.patch, gnu/packages/patches/icecat-CVE-2015-2724-pt2.patch, gnu/packages/patches/icecat-CVE-2015-2724-pt3.patch, gnu/packages/patches/icecat-CVE-2015-2724-pt4.patch, gnu/packages/patches/icecat-CVE-2015-2728-pt1.patch, gnu/packages/patches/icecat-CVE-2015-2728-pt2.patch, gnu/packages/patches/icecat-CVE-2015-2733-pt1.patch, gnu/packages/patches/icecat-CVE-2015-2733-pt2.patch, gnu/packages/patches/icecat-CVE-2015-2735.patch, gnu/packages/patches/icecat-CVE-2015-2736.patch, gnu/packages/patches/icecat-CVE-2015-2738.patch, gnu/packages/patches/icecat-CVE-2015-2739.patch, gnu/packages/patches/icecat-CVE-2015-2740.patch, gnu/packages/patches/icecat-CVE-2015-2743.patch: New files. * gnu-system.am (dist_patch_DATA): Add them. * gnu/packages/gnuzilla.scm (icecat)[source]: Add patches.
Diffstat (limited to 'gnu/packages/patches/icecat-CVE-2015-2733-pt2.patch')
-rw-r--r--gnu/packages/patches/icecat-CVE-2015-2733-pt2.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/patches/icecat-CVE-2015-2733-pt2.patch b/gnu/packages/patches/icecat-CVE-2015-2733-pt2.patch
new file mode 100644
index 0000000000..cc74a33871
--- /dev/null
+++ b/gnu/packages/patches/icecat-CVE-2015-2733-pt2.patch
@@ -0,0 +1,31 @@
+From 72cd6e97ae12b89659cd59788bad08cd2f514eff Mon Sep 17 00:00:00 2001
+From: Andrea Marchesini <amarchesini@mozilla.com>
+Date: Fri, 12 Jun 2015 10:06:19 -0400
+Subject: [PATCH] Bug 1169867 - XMLHttpRequest::SendInternal should not unpin
+ itself when the worker goes away. r=bent, a=abillings
+
+--HG--
+extra : transplant_source : %28%B3%BD%9D%E2p%F3%BE%94S%CCD%08%8B%07%8A%CC%17%B0%7B
+---
+ dom/workers/XMLHttpRequest.cpp | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/dom/workers/XMLHttpRequest.cpp b/dom/workers/XMLHttpRequest.cpp
+index 5690af5..d425eac 100644
+--- a/dom/workers/XMLHttpRequest.cpp
++++ b/dom/workers/XMLHttpRequest.cpp
+@@ -1829,6 +1829,11 @@ XMLHttpRequest::SendInternal(const nsAString& aStringBody,
+ new SendRunnable(mWorkerPrivate, mProxy, aStringBody, Move(aBody),
+ aClonedObjects, syncLoopTarget, hasUploadListeners);
+ if (!runnable->Dispatch(cx)) {
++ // Dispatch() may have spun the event loop and we may have already unrooted.
++ // If so we don't want autoUnpin to try again.
++ if (!mRooted) {
++ autoUnpin.Clear();
++ }
+ aRv.Throw(NS_ERROR_FAILURE);
+ return;
+ }
+--
+2.4.3
+