aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/go-skip-gc-test.patch
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-10-08 11:23:22 +0200
committerLudovic Courtès <ludo@gnu.org>2019-10-08 11:37:07 +0200
commitcf3d1763ede1a329c2bc932c84591ab594bb6c96 (patch)
tree665f92418f8671474de3815241fb657384463c94 /gnu/packages/patches/go-skip-gc-test.patch
parentd57660c54907cc6fba8b0adf6295fd2311ada6cf (diff)
parent2fa55c72476c73211cbb2d6b29c05a1ad58a6cf9 (diff)
downloadguix-cf3d1763ede1a329c2bc932c84591ab594bb6c96.tar
guix-cf3d1763ede1a329c2bc932c84591ab594bb6c96.tar.gz
Merge branch 'core-updates'
Diffstat (limited to 'gnu/packages/patches/go-skip-gc-test.patch')
-rw-r--r--gnu/packages/patches/go-skip-gc-test.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/patches/go-skip-gc-test.patch b/gnu/packages/patches/go-skip-gc-test.patch
new file mode 100644
index 0000000000..2baab97580
--- /dev/null
+++ b/gnu/packages/patches/go-skip-gc-test.patch
@@ -0,0 +1,17 @@
+Skip a GC test known to be flaky:
+
+ https://issues.guix.gnu.org/issue/37425
+ https://github.com/golang/go/issues/27636
+
+--- go/src/runtime/gc_test.go 2019-09-16 23:10:18.200680387 +0200
++++ go/src/runtime/gc_test.go 2019-09-16 23:11:50.324360646 +0200
+@@ -27,6 +27,9 @@ func TestGcSys(t *testing.T) {
+ if runtime.GOOS == "linux" && runtime.GOARCH == "arm64" {
+ t.Skip("skipping test; GOOS=linux GOARCH=arm64 https://github.com/golang/go/issues/27636")
+ }
++ if runtime.GOOS == "linux" {
++ t.Skip("skipping test; GOOS=linux https://issues.guix.gnu.org/issue/37425")
++ }
+ got := runTestProg(t, "testprog", "GCSys")
+ want := "OK\n"
+ if got != want {