aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/go-skip-gc-test.patch
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-09-16 23:45:36 +0200
committerLudovic Courtès <ludo@gnu.org>2019-09-16 23:45:36 +0200
commitb938892551816aedd01fd32b7eb1d5e061afce32 (patch)
treeee8c07645ff159ffe7620207ed0ac54831869939 /gnu/packages/patches/go-skip-gc-test.patch
parent0b2ea78173f05c417a9002e52e2b36b139074124 (diff)
downloadguix-b938892551816aedd01fd32b7eb1d5e061afce32.tar
guix-b938892551816aedd01fd32b7eb1d5e061afce32.tar.gz
gnu: go@1.12: Skip flaky GC test.
Fixes <https://bugs.gnu.org/37425>. * gnu/packages/patches/go-skip-gc-test.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/golang.scm (go-1.12)[source]: Use it.
Diffstat (limited to 'gnu/packages/patches/go-skip-gc-test.patch')
-rw-r--r--gnu/packages/patches/go-skip-gc-test.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/patches/go-skip-gc-test.patch b/gnu/packages/patches/go-skip-gc-test.patch
new file mode 100644
index 0000000000..2baab97580
--- /dev/null
+++ b/gnu/packages/patches/go-skip-gc-test.patch
@@ -0,0 +1,17 @@
+Skip a GC test known to be flaky:
+
+ https://issues.guix.gnu.org/issue/37425
+ https://github.com/golang/go/issues/27636
+
+--- go/src/runtime/gc_test.go 2019-09-16 23:10:18.200680387 +0200
++++ go/src/runtime/gc_test.go 2019-09-16 23:11:50.324360646 +0200
+@@ -27,6 +27,9 @@ func TestGcSys(t *testing.T) {
+ if runtime.GOOS == "linux" && runtime.GOARCH == "arm64" {
+ t.Skip("skipping test; GOOS=linux GOARCH=arm64 https://github.com/golang/go/issues/27636")
+ }
++ if runtime.GOOS == "linux" {
++ t.Skip("skipping test; GOOS=linux https://issues.guix.gnu.org/issue/37425")
++ }
+ got := runTestProg(t, "testprog", "GCSys")
+ want := "OK\n"
+ if got != want {