aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/glib-tests-timer.patch
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2016-04-23 13:13:53 -0400
committerMark H Weaver <mhw@netris.org>2016-04-23 13:13:53 -0400
commite969b140a4382fd91514439a57749379cf00f86b (patch)
treec5c5adfc0c7c4cd0c367fa37203637e6d655544c /gnu/packages/patches/glib-tests-timer.patch
parent267061ba0bc6df0d61081b97d650d95acec8178a (diff)
downloadguix-e969b140a4382fd91514439a57749379cf00f86b.tar
guix-e969b140a4382fd91514439a57749379cf00f86b.tar.gz
Revert "Merge branch 'gnome-updates'"
This reverts commit 63655d459e28b09cd8d58743dae14b3460f6c9da, reversing changes made to 80627f51f0238b9450745f4e642172d059ca5bb5.
Diffstat (limited to 'gnu/packages/patches/glib-tests-timer.patch')
-rw-r--r--gnu/packages/patches/glib-tests-timer.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/patches/glib-tests-timer.patch b/gnu/packages/patches/glib-tests-timer.patch
index e37425c0c8..1ac364fcc1 100644
--- a/gnu/packages/patches/glib-tests-timer.patch
+++ b/gnu/packages/patches/glib-tests-timer.patch
@@ -2,6 +2,9 @@
fail depending on the elapsed microseconds. Improve rounding by adding a
fractional bit.
+* The /timer/stop test fails if compiler optimizations are enabled, which they
+ are by default. Disable that test.
+
--- glib-2.40.0/glib/tests/timer.c 2014-03-05 08:05:42.000000000 -0600
+++ glib-2.40.0/glib/tests/timer.c 2014-07-10 16:33:12.746862822 -0500
@@ -35,7 +35,7 @@
@@ -13,3 +16,11 @@
g_timer_destroy (timer);
}
+@@ -204,7 +204,6 @@
+ g_test_init (&argc, &argv, NULL);
+
+ g_test_add_func ("/timer/basic", test_timer_basic);
+- g_test_add_func ("/timer/stop", test_timer_stop);
+ g_test_add_func ("/timer/continue", test_timer_continue);
+ g_test_add_func ("/timer/reset", test_timer_reset);
+ g_test_add_func ("/timeval/add", test_timeval_add);