aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/calibre-no-updates-dialog.patch
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-03-24 20:35:37 +0100
committerAndreas Enge <andreas@enge.fr>2015-03-24 20:35:37 +0100
commitb655b2154c8a72f5c9b7e54594653df49f3c2c02 (patch)
tree51ecf5c6580dfddd0a6b8403dd5284850f0fed56 /gnu/packages/patches/calibre-no-updates-dialog.patch
parent2c16316ef4420b462a1147e8eaee4680093616fd (diff)
downloadguix-b655b2154c8a72f5c9b7e54594653df49f3c2c02.tar
guix-b655b2154c8a72f5c9b7e54594653df49f3c2c02.tar.gz
gnu: calibre: Add a patch to avoid automatic checking for updates.
* gnu/packages/patches/calibre-no-updates-dialog.patch: New file. * gnu-system.am (dist_patch_DATA): Register patch. * gnu/packages/ebook.scm (calibre): Use patch.
Diffstat (limited to 'gnu/packages/patches/calibre-no-updates-dialog.patch')
-rw-r--r--gnu/packages/patches/calibre-no-updates-dialog.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/patches/calibre-no-updates-dialog.patch b/gnu/packages/patches/calibre-no-updates-dialog.patch
new file mode 100644
index 0000000000..1d8d79660e
--- /dev/null
+++ b/gnu/packages/patches/calibre-no-updates-dialog.patch
@@ -0,0 +1,18 @@
+Taken from debian.
+
+# Description: Disable update check by default.
+Index: calibre/src/calibre/gui2/main.py
+===================================================================
+--- calibre.orig/src/calibre/gui2/main.py 2014-02-02 10:41:28.470954623 +0100
++++ calibre/src/calibre/gui2/main.py 2014-02-02 10:41:56.546954247 +0100
+@@ -37,8 +37,8 @@
+ help=_('Start minimized to system tray.'))
+ parser.add_option('-v', '--verbose', default=0, action='count',
+ help=_('Ignored, do not use. Present only for legacy reasons'))
+- parser.add_option('--no-update-check', default=False, action='store_true',
+- help=_('Do not check for updates'))
++ parser.add_option('--update-check', dest='no_update_check', default=True, action='store_false',
++ help=_('Check for updates'))
+ parser.add_option('--ignore-plugins', default=False, action='store_true',
+ help=_('Ignore custom plugins, useful if you installed a plugin'
+ ' that is preventing calibre from starting'))