aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/biber-fix-encoding-write.patch
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-01-09 10:48:42 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-01-09 10:52:41 +0200
commit0e289672503a4e1599ef826d49f2fa5575081942 (patch)
treecdaec28207956090b7cebff805135754dcb22f06 /gnu/packages/patches/biber-fix-encoding-write.patch
parent0109b89c5834b5374f248dc3681702180013f41f (diff)
parent6df4d8338d2bf94ab729e3b12e42ace0a06687ae (diff)
downloadguix-0e289672503a4e1599ef826d49f2fa5575081942.tar
guix-0e289672503a4e1599ef826d49f2fa5575081942.tar.gz
Merge remote-tracking branch 'origin/master' into staging
Diffstat (limited to 'gnu/packages/patches/biber-fix-encoding-write.patch')
-rw-r--r--gnu/packages/patches/biber-fix-encoding-write.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/patches/biber-fix-encoding-write.patch b/gnu/packages/patches/biber-fix-encoding-write.patch
new file mode 100644
index 0000000000..56cd11212e
--- /dev/null
+++ b/gnu/packages/patches/biber-fix-encoding-write.patch
@@ -0,0 +1,31 @@
+From 2a9b15aefb842a734637f3d230936ea1b7c60096 Mon Sep 17 00:00:00 2001
+From: Philip Kime <Philip@kime.org.uk>
+Date: Thu, 8 Nov 2018 22:02:09 +0100
+Subject: [PATCH] Fix to address #239
+
+---
+ lib/Biber.pm | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/lib/Biber.pm b/lib/Biber.pm
+index 8b1f80a5..d97fca29 100644
+--- a/lib/Biber.pm
++++ b/lib/Biber.pm
+@@ -311,6 +311,8 @@ sub parse_ctrlfile {
+ unless (eval {$checkbuf = File::Slurper::read_text($ctrl_file_path, 'latin1')}) {
+ biber_error("$ctrl_file_path is not UTF-8 or even latin1, how horrible.");
+ }
++ # Write ctrl file as UTF-8
++ File::Slurper::write_text($ctrl_file_path, NFC($checkbuf));# Unicode NFC boundary
+ }
+
+ $checkbuf = NFD($checkbuf);# Unicode NFD boundary
+@@ -319,8 +321,6 @@ sub parse_ctrlfile {
+ unlink($output) unless $output eq '-';# ignore deletion of STDOUT marker
+ biber_error("$ctrl_file_path is malformed, last biblatex run probably failed. Deleted $output");
+ }
+- # Write ctrl file as UTF-8
+- File::Slurper::write_text($ctrl_file_path, NFC($checkbuf));# Unicode NFC boundary
+
+ # Validate if asked to
+ if (Biber::Config->getoption('validate_control')) {