aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/ath9k-htc-firmware-objcopy.patch
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-10-28 23:07:57 +0100
committerLudovic Courtès <ludo@gnu.org>2014-10-29 00:31:23 +0100
commit4902c3ecc6b74493f0c4f29efdffc46b187f2b11 (patch)
tree2c0b78dbe21d583c1e4f1e79d4ee8f8e8bf772ef /gnu/packages/patches/ath9k-htc-firmware-objcopy.patch
parent9d3074609a3fb0712e0102dbbb4d7bdabb58d142 (diff)
downloadguix-4902c3ecc6b74493f0c4f29efdffc46b187f2b11.tar
guix-4902c3ecc6b74493f0c4f29efdffc46b187f2b11.tar.gz
gnu: Add ath9k-htc-firmware.
* gnu/packages/firmware.scm: New file. * gnu/packages/patches/ath9k-htc-firmware-objcopy.patch: New file. * gnu-system.am (GNU_SYSTEM_MODULES): Add 'firmware.scm'. (dist_patch_DATA): Add the patch.
Diffstat (limited to 'gnu/packages/patches/ath9k-htc-firmware-objcopy.patch')
-rw-r--r--gnu/packages/patches/ath9k-htc-firmware-objcopy.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/patches/ath9k-htc-firmware-objcopy.patch b/gnu/packages/patches/ath9k-htc-firmware-objcopy.patch
new file mode 100644
index 0000000000..2172f8353f
--- /dev/null
+++ b/gnu/packages/patches/ath9k-htc-firmware-objcopy.patch
@@ -0,0 +1,14 @@
+The firmware is cross-compiled, but the build system ends up using
+'objcopy' instead of 'xtensa-elf-objcopy' by default. Force it to
+use the right one.
+
+--- source/target_firmware/configure 2014-10-28 20:57:26.834436561 +0100
++++ source/target_firmware/configure 2014-10-28 20:57:29.666436530 +0100
+@@ -11,6 +11,7 @@ mkdir -p build
+ cat > "$TOOLCHAIN_FILE" <<EOF
+ INCLUDE(CMakeForceCompiler)
+
++SET(CMAKE_OBJCOPY xtensa-elf-objcopy)
+ SET(CMAKE_SYSTEM_PROCESSOR xtensa)
+ SET(CMAKE_FIND_ROOT_PATH ${TOOLCHAIN}/$TARGET)
+ SET(CMAKE_STRIP :)