aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ots.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-03-22 12:57:37 +0200
committerEfraim Flashner <efraim@flashner.co.il>2017-03-22 12:57:37 +0200
commit378de69c59ee0700c67b10b38592c213821b41f2 (patch)
treeee9b6465430077a79cace3cb8fab1a85a8c1e4c5 /gnu/packages/ots.scm
parent049e02eaa258942515260a58c8d9ddfc4e7caffe (diff)
parentd8be338f16c7da4acfa55f29f58beaf908d3ad60 (diff)
downloadguix-378de69c59ee0700c67b10b38592c213821b41f2.tar
guix-378de69c59ee0700c67b10b38592c213821b41f2.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates
Diffstat (limited to 'gnu/packages/ots.scm')
-rw-r--r--gnu/packages/ots.scm34
1 files changed, 20 insertions, 14 deletions
diff --git a/gnu/packages/ots.scm b/gnu/packages/ots.scm
index f1900746b6..73dd5e4832 100644
--- a/gnu/packages/ots.scm
+++ b/gnu/packages/ots.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Marek Benc <merkur32@gmail.com>
+;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -35,9 +36,13 @@
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://sourceforge/libots/libots/"
- name "-" version "/" name "-" version
- ".tar.gz"))
+ ;; libots seems to have left sourceforge and taken their release
+ ;; tarballs with them
+ (uri (list (string-append "mirror://debian/pool/main/o/ots/ots_"
+ version ".orig.tar.gz")
+ (string-append "mirror://sourceforge/libots/libots/"
+ name "-" version "/" name "-" version
+ ".tar.gz")))
(sha256
(base32 "0dz1ccd7ymzk4swz1aly4im0k3pascnshmgg1whd2rk14li8v47a"))
(patches (search-patches "ots-no-include-missing-file.patch"))))
@@ -48,17 +53,18 @@
;; before libots-1.la has been built.
'(#:parallel-build? #f
- #:phases (alist-cons-after
- 'configure 'set-shared-lib-extension
- (lambda _
- ;; For some reason, the 'libtool' script (from Libtool
- ;; 1.5.2, Debian variant) sets 'shrext_cmds' instead of
- ;; 'shrext' for the shared library file name extension.
- ;; This leads to the creation of 'libots-1' instead of
- ;; 'libots-1.so'. Fix that.
- (substitute* "libtool"
- (("shrext_cmds") "shrext")))
- %standard-phases)))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'configure 'set-shared-lib-extension
+ (lambda _
+ ;; For some reason, the 'libtool' script (from Libtool
+ ;; 1.5.2, Debian variant) sets 'shrext_cmds' instead of
+ ;; 'shrext' for the shared library file name extension.
+ ;; This leads to the creation of 'libots-1' instead of
+ ;; 'libots-1.so'. Fix that.
+ (substitute* "libtool"
+ (("shrext_cmds") "shrext"))
+ #t)))))
(inputs
`(("glib" ,glib)
("popt" ,popt)