aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-05-21 16:34:02 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-05-25 14:47:54 +0200
commit9b8bc95747eacea94762c806c60dd19f6a717cad (patch)
tree766190565f6a1b2da893ba9619e5c94bb88e958f /gnu/packages/ocaml.scm
parentc64fecc20b4c1a4fdf4fe6daa6a6cb7217d04777 (diff)
downloadguix-9b8bc95747eacea94762c806c60dd19f6a717cad.tar
guix-9b8bc95747eacea94762c806c60dd19f6a717cad.tar.gz
gnu: Add ocaml-ppx-sexp-message.
* gnu/packages/ocaml.scm (ocaml-ppx-sexp-message): New variable.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 29fbf9cf36..223cecc951 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2760,3 +2760,28 @@ position.")
(description "Extensions to printf-style format-strings for user-defined
string conversion.")
(license license:asl2.0)))
+
+(define-public ocaml-ppx-sexp-message
+ (package
+ (name "ocaml-ppx-sexp-message")
+ (version "113.33.03")
+ (source (janestreet-origin "ppx_sexp_message" version
+ "084w1l3gnyw4ri9vbn7bv9b2xkw1520qczfxpxdarfivdrz8xr68"))
+ (build-system ocaml-build-system)
+ (native-inputs
+ `(("js-build-tools" ,ocaml-js-build-tools)
+ ("opam" ,opam)))
+ (propagated-inputs
+ `(("ppx-driver" ,ocaml-ppx-driver)
+ ("ppx-here" ,ocaml-ppx-here)
+ ("ppx-sexp-conv" ,ocaml-ppx-sexp-conv)
+ ("ppx-tools" ,ocaml-ppx-tools)
+ ("ppx-core" ,ocaml-ppx-core)))
+ (arguments janestreet-arguments)
+ (home-page "https://github.com/janestreet/ppx_sexp_message/")
+ (synopsis "A ppx rewriter for easy construction of s-expressions")
+ (description "Ppx_sexp_message aims to ease the creation of s-expressions
+in OCaml. This is mainly motivated by writing error and debugging messages,
+where one needs to construct a s-expression based on various element of the
+context such as function arguments.")
+ (license license:asl2.0)))