aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-05-21 16:31:23 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-05-25 14:47:50 +0200
commit7ea5acc6684cbe31d8c95c5dd569487e96852fff (patch)
tree0dd46d0c72c3f2a082631ad97b45b180356af665 /gnu/packages/ocaml.scm
parent5d6d7ab0cfdfac278e7fefdd41c8516e973ffb78 (diff)
downloadguix-7ea5acc6684cbe31d8c95c5dd569487e96852fff.tar
guix-7ea5acc6684cbe31d8c95c5dd569487e96852fff.tar.gz
gnu: Add ocaml-ppx-fail.
* gnu/packages/ocaml.scm (ocaml-ppx-fail): New variable.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 7d6a77d721..c2f4ed972e 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2716,3 +2716,25 @@ ocaml values.")
(description "Generation of binary serialization and deserialization
functions from type definitions.")
(license license:asl2.0)))
+
+(define-public ocaml-ppx-fail
+ (package
+ (name "ocaml-ppx-fail")
+ (version "113.33.03")
+ (source (janestreet-origin "ppx_fail" version
+ "1dwgad0f05gqp5rnwf9dcasidpfi7q3mrpazsw3a2vijjblbhjgn"))
+ (build-system ocaml-build-system)
+ (native-inputs
+ `(("js-build-tools" ,ocaml-js-build-tools)
+ ("opam" ,opam)))
+ (propagated-inputs
+ `(("ppx-driver" ,ocaml-ppx-driver)
+ ("ppx-tools" ,ocaml-ppx-tools)
+ ("ppx-here" ,ocaml-ppx-here)
+ ("ppx-core" ,ocaml-ppx-core)))
+ (arguments janestreet-arguments)
+ (home-page "https://github.com/janestreet/ppx_fail/")
+ (synopsis "Add location to calls to failwiths")
+ (description "Syntax extension that makes [failwiths] always include a
+position.")
+ (license license:asl2.0)))