aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-05-21 16:28:24 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-05-25 14:47:22 +0200
commit25941ca13b483758802d9b68abd40b6cb73df8cf (patch)
treec1044760cdea052d8c1c4294cff98ee66878a887 /gnu/packages/ocaml.scm
parent20ed093977cc80ba1729c38e05ae7955a38069a6 (diff)
downloadguix-25941ca13b483758802d9b68abd40b6cb73df8cf.tar
guix-25941ca13b483758802d9b68abd40b6cb73df8cf.tar.gz
gnu: Add ocaml-ppx-sexp-value.
* gnu/packages/ocaml.scm (ocaml-ppx-sexp-value): New variable.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index b9f1d53cf6..0a1174402d 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2650,3 +2650,26 @@ match expressions, and if expressions.")
(synopsis "Generation of runtime types from type declarations")
(description "Automatic generation of runtime types from type definitions.")
(license license:asl2.0)))
+
+(define-public ocaml-ppx-sexp-value
+ (package
+ (name "ocaml-ppx-sexp-value")
+ (version "113.33.03")
+ (source (janestreet-origin "ppx_sexp_value" version
+ "0m3ag23mbqm0i2pv1dzilfks15ipa5q60mf57a0cd3p0pvarq10g"))
+ (build-system ocaml-build-system)
+ (native-inputs
+ `(("js-build-tools" ,ocaml-js-build-tools)
+ ("opam" ,opam)))
+ (propagated-inputs
+ `(("ppx-driver" ,ocaml-ppx-driver)
+ ("ppx-here" ,ocaml-ppx-here)
+ ("ppx-sexp-conv" ,ocaml-ppx-sexp-conv)
+ ("ppx-tools" ,ocaml-ppx-tools)
+ ("ppx-core" ,ocaml-ppx-core)))
+ (arguments janestreet-arguments)
+ (home-page "https://github.com/janestreet/ppx_sexp_value/")
+ (synopsis "Simplify building s-expressions from ocaml values")
+ (description "A ppx rewriter that simplifies building s-expressions from
+ocaml values.")
+ (license license:asl2.0)))