aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorpukkamustard <pukkamustard@posteo.net>2020-12-28 22:10:10 +0100
committerJulien Lepiller <julien@lepiller.eu>2020-12-30 14:26:04 +0100
commitad6a057724b1f376fdd747de953561cee72720a0 (patch)
treefc1fb82696674c8a73e3e285a03da4d25af5a9cb /gnu/packages/ocaml.scm
parent1a5bca9b3b143b3d9f234c95d8d2c43ca637de17 (diff)
downloadguix-ad6a057724b1f376fdd747de953561cee72720a0.tar
guix-ad6a057724b1f376fdd747de953561cee72720a0.tar.gz
gnu: ocaml-markup: Update to 1.0.0.
* gnu/packages/ocaml.scm (ocaml-markup): Update to 1.0.0. (ocaml-markup0.8.0): New variable. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm28
1 files changed, 25 insertions, 3 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 273dc2572c..e3dca82e47 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5533,7 +5533,7 @@ the full Core is not available, such as in Javascript.")
(define-public ocaml-markup
(package
(name "ocaml-markup")
- (version "0.8.2")
+ (version "1.0.0")
(home-page "https://github.com/aantron/markup.ml")
(source
(origin
@@ -5544,7 +5544,7 @@ the full Core is not available, such as in Javascript.")
(file-name (git-file-name name version))
(sha256
(base32
- "13zcrwzjmifniv3bvjbkd2ah8wwa3ld75bxh1d8hrzdvfxzh9szn"))))
+ "09hkrf9pw6hpb9j06p5bddklpnjwdjpqza3bx2179l970yl67an9"))))
(build-system dune-build-system)
(arguments
`(#:package "markup"))
@@ -5556,8 +5556,10 @@ the full Core is not available, such as in Javascript.")
("ocaml-uutf" ,ocaml-uutf)
("ocaml-lwt" ,ocaml-lwt)))
(native-inputs
- `(("ocaml-ounit" ,ocaml-ounit)
+ `(("ocaml-ounit2" ,ocaml-ounit2)
("pkg-config" ,pkg-config)))
+ (properties
+ `((ocaml4.07-variant . ,(delay (package-with-ocaml4.07 ocaml-markup0.8.0)))))
(synopsis "Error-recovering functional HTML5 and XML parsers and writers")
(description "Markup.ml provides an HTML parser and an XML parser. The
parsers are wrapped in a simple interface: they are functions that transform
@@ -5579,6 +5581,26 @@ a single pass. They automatically detect the character encoding of the input
stream, and convert everything to UTF-8.")
(license license:bsd-3)))
+;; ocaml-markup 1.0.0 can not be built with old version of dune used in
+;; package-with-ocaml4.07
+(define-public ocaml-markup0.8.0
+ (package
+ (inherit ocaml-markup)
+ (name "ocaml-markup")
+ (version "0.8.0")
+ (home-page "https://github.com/aantron/markup.ml")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append home-page ".git"))
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0aif4abvfmi9xc1pvw5n5rbm6rzkkpsxyvdn0lanr33rjpvkwdlm"))))
+ (properties '())))
+
(define-public ocaml-tyxml
(package
(name "ocaml-tyxml")