aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-09-02 15:57:56 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-09-02 15:57:56 +0200
commit30dfac27a5642c36e7bb1ba7966566864ba2d28d (patch)
tree3b59623014eeea1df02cda5f926d803b9a36a828 /gnu/packages/ocaml.scm
parentd2ee294c0400ac8f2a10f10c3c9644da513a3712 (diff)
parent65e4109cdc96fbaee088f50d0138af8acef43141 (diff)
downloadguix-30dfac27a5642c36e7bb1ba7966566864ba2d28d.tar
guix-30dfac27a5642c36e7bb1ba7966566864ba2d28d.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 43bbdcd6e2..2597775bf7 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -575,6 +575,46 @@ assistant to write formal mathematical proofs using a variety of theorem
provers.")
(license license:gpl2+)))
+(define-public emacs-tuareg
+ (package
+ (name "emacs-tuareg")
+ (version "2.0.10")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/ocaml/tuareg/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1r2smclcs63n74lcyckbp90j09wyjdngn816cqzfkw54iwh3hd7q"))))
+ (build-system gnu-build-system)
+ (native-inputs `(("emacs" ,emacs-minimal)
+ ("opam" ,opam)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'install 'fix-install-path
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "Makefile"
+ (("/emacs/site-lisp")
+ (string-append (assoc-ref %outputs "out")
+ "/share/emacs/site-lisp/")))
+ #t))
+ (add-after 'install 'post-install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (symlink "tuareg.el"
+ (string-append (assoc-ref outputs "out")
+ "/share/emacs/site-lisp/"
+ "tuareg-autoloads.el"))
+ #t)))))
+ (home-page "https://github.com/ocaml/tuareg")
+ (synopsis "OCaml programming mode, REPL, debugger for Emacs")
+ (description "Tuareg helps editing OCaml code, to highlight important
+parts of the code, to run an OCaml REPL, and to run the OCaml debugger within
+Emacs.")
+ (license license:gpl2+)))
+
(define-public ocaml-menhir
(package
(name "ocaml-menhir")