aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-02-01 17:52:37 +0100
committerJulien Lepiller <julien@lepiller.eu>2019-02-05 22:33:35 +0100
commit6692f652182314eeeab4aad634084ec60d81f035 (patch)
tree780390fdc2be1ed54ac094cce0647c3fc2222b96 /gnu/packages/ocaml.scm
parent49b01fa3e9b780d62c1ead54a472aa607bd2a495 (diff)
downloadguix-6692f652182314eeeab4aad634084ec60d81f035.tar
guix-6692f652182314eeeab4aad634084ec60d81f035.tar.gz
gnu: Add ocaml-ppx-hash.
* gnu/packages/ocaml.scm (ocaml-ppx-hash): New variable.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index b5f63ba28a..f01eb37ad7 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5408,3 +5408,29 @@ storage of large amounts of data.")
(synopsis "Ocamldoc comment syntax parser")
(description "Octavius is a library to parse the `ocamldoc` comment syntax.")
(license license:isc)))
+
+(define-public ocaml-ppx-hash
+ (package
+ (name "ocaml-ppx-hash")
+ (version "0.11.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/janestreet/ppx_hash.git")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "1p0ic6aijxlrdggpmycj12q3cy9xksbq2vq727215maz4snvlf5p"))))
+ (build-system dune-build-system)
+ (propagated-inputs
+ `(("ocaml-base" ,ocaml-base)
+ ("ocaml-ppx-compare" ,ocaml-ppx-compare)
+ ("ocaml-ppx-sexp-conv" ,ocaml-ppx-sexp-conv)
+ ("ocaml-migrate-parsetree" ,ocaml-migrate-parsetree)
+ ("ocaml-ppxlib" ,ocaml-ppxlib)))
+ (properties `((upstream-name . "ppx_hash")))
+ (home-page "https://github.com/janestreet/ppx_hash")
+ (synopsis "Generation of hash functions from type expressions and definitions")
+ (description "This package is a collecton of ppx rewriters that generate
+hash functions from type exrpessions and definitions.")
+ (license license:asl2.0)))