aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/node.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-06-29 18:02:17 -0400
committerLeo Famulari <leo@famulari.name>2017-06-29 18:02:17 -0400
commit1024c8119c71ba3ec0122238e8d8254b08d29187 (patch)
treead12a1aac7f828791154a1786d4f245db71b46e9 /gnu/packages/node.scm
parent92cb946bd9d78cb8f6aa8418d505f52da6894ab4 (diff)
parent95bbaa02aa63bc5eae36f686f1ed9915663aa4cf (diff)
downloadguix-1024c8119c71ba3ec0122238e8d8254b08d29187.tar
guix-1024c8119c71ba3ec0122238e8d8254b08d29187.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/node.scm')
-rw-r--r--gnu/packages/node.scm14
1 files changed, 11 insertions, 3 deletions
diff --git a/gnu/packages/node.scm b/gnu/packages/node.scm
index 69bd928833..d4415fc501 100644
--- a/gnu/packages/node.scm
+++ b/gnu/packages/node.scm
@@ -40,14 +40,14 @@
(define-public node
(package
(name "node")
- (version "7.10.0")
+ (version "8.1.2")
(source (origin
(method url-fetch)
(uri (string-append "http://nodejs.org/dist/v" version
"/node-v" version ".tar.gz"))
(sha256
(base32
- "00vdmb0z8b2sd547bkksgy9dfq5gi5xfd9b3f0rc4ngvpzl3z164"))
+ "0l92gar1pivzaiwffiiiz2f2m5k39sl5fphlfnvy0ml9hrjb65yp"))
;; https://github.com/nodejs/node/pull/9077
(patches (search-patches "node-9077.patch"))))
(build-system gnu-build-system)
@@ -83,10 +83,18 @@
((" \\$\\(MAKE\\) jslint") "")
((" \\$\\(MAKE\\) cpplint\n") ""))
+ ;; FIXME: This test seems to depends on files that are not
+ ;; available in the bundled v8. See
+ ;; https://github.com/nodejs/node/issues/13344
+ (for-each delete-file
+ '("test/addons-napi/test_general/testInstanceOf.js"))
;; FIXME: These tests fail in the build container, but they don't
;; seem to be indicative of real problems in practice.
(for-each delete-file
- '("test/parallel/test-dgram-membership.js"
+ '("test/async-hooks/test-ttywrap.readstream.js"
+ "test/parallel/test-util-inspect.js"
+ "test/parallel/test-v8-serdes.js"
+ "test/parallel/test-dgram-membership.js"
"test/parallel/test-cluster-master-error.js"
"test/parallel/test-cluster-master-kill.js"
"test/parallel/test-npm-install.js"