aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-03-14 11:56:08 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-03-14 18:23:46 +0100
commitf3fda2980cd6c6cb1911c278c45e40efd81c5163 (patch)
treec03d883559377d83db2085ed95ee6a0b88625454 /gnu/packages/networking.scm
parentaac6cbbfede0bbfafdbbeeb460f00a244333895d (diff)
downloadguix-f3fda2980cd6c6cb1911c278c45e40efd81c5163.tar
guix-f3fda2980cd6c6cb1911c278c45e40efd81c5163.tar.gz
gnu: macchanger: Update to 1.7.0.
* gnu/packages/networking.scm (macchanger): Update to 1.7.0. [source]: Update URI.
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm21
1 files changed, 13 insertions, 8 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index bf4bee2f87..395e75afa6 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -87,17 +87,22 @@
#:use-module (gnu packages xml)
#:use-module (ice-9 match))
+;; The gnu.org ‘home’ for this GNU project is a directory listing with 1.6.0 as
+;; the latest version. The author's git repository, mentioned in the 1.6.0
+;; README and otherwise legit-looking, contains a proper 1.7.0 release tarball
+;; with many OUI updates. Use it, even though it's also several years old now.
(define-public macchanger
(package
(name "macchanger")
- (version "1.6.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/"
- name "/" name "-" version ".tar.gz"))
- (sha256
- (base32
- "1xsiivjjyhqcs6dyjcshrnxlgypvyfzacjz7gcjgl88xiw9lylri"))))
+ (version "1.7.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/alobbs/macchanger/"
+ "releases/download/" version "/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1gs5m0jxyprdp00w2qkbnaqm3ilkjz0q1gqdg4nzdm8g4xy73qns"))))
(build-system gnu-build-system)
(home-page "https://www.gnu.org/software/macchanger/")
(synopsis "Viewing and manipulating MAC addresses of network interfaces")