aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorRaimon Grau <raimon@3scale.net>2016-03-10 12:47:56 +0000
committerLeo Famulari <leo@famulari.name>2016-03-10 16:48:16 -0500
commit9514662322d4f2892e5a7c21ba60776314686d58 (patch)
treeb045d4478a9270eeed92b187526e6286d80dbf05 /gnu/packages/networking.scm
parentff22f01d671b35ebffda6b7badbf17801c52b92e (diff)
downloadguix-9514662322d4f2892e5a7c21ba60776314686d58.tar
guix-9514662322d4f2892e5a7c21ba60776314686d58.tar.gz
gnu: Add nload.
* gnu/packages/networking.scm (nload): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index e7311833ed..ac7e4e70e6 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Stefan Reichör <stefan@xsteve.at>
+;;; Copyright © 2016 Raimon Grau <raimonster@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -187,3 +188,25 @@ needed/wanted real-time traffic statistics of multiple network
interfaces, with a simple and efficient view on the command line. It is
intended as a substitute for the PPPStatus and EthStatus projects.")
(license license:gpl2+)))
+
+(define-public nload
+ (package
+ (name "nload")
+ (version "0.7.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/nload/nload-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1rb9skch2kgqzigf19x8bzk211jdfjfdkrcvaqyj89jy2pkm3h61"))))
+ (build-system gnu-build-system)
+ (inputs `(("ncurses" ,ncurses)))
+ (home-page "http://www.roland-riegel.de/nload/")
+ (synopsis "Realtime console network usage monitor")
+ (description
+ "Nload is a console application which monitors network traffic and
+bandwidth usage in real time. It visualizes the in- and outgoing traffic using
+two graphs and provides additional info like total amount of transfered data
+and min/max network usage.")
+ (license license:gpl2+)))