aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-01-17 18:15:50 -0800
committerLeo Famulari <leo@famulari.name>2018-01-17 18:22:35 -0800
commit491f7fc023ed546ca1fd08433fd0589b8b747703 (patch)
treeca06cb3bf2bc45cde744350cfbf4c76801526852 /gnu/packages/networking.scm
parent3ef273377e9435f3f295fd8e268729f378a575e7 (diff)
downloadguix-491f7fc023ed546ca1fd08433fd0589b8b747703.tar
guix-491f7fc023ed546ca1fd08433fd0589b8b747703.tar.gz
gnu: thc-ipv6: Update to 3.4-0.4bb7257.
* gnu/packages/networking.scm (thc-ipv6): Update to 3.4-0.4bb7257. [source]: Use git-fetch.
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm86
1 files changed, 45 insertions, 41 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 2c55d6793a..26eb1820e6 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -38,6 +38,7 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix build-system cmake)
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system gnu)
@@ -1422,49 +1423,52 @@ updates to the zebra daemon.")
(license license:gpl2+)))
(define-public thc-ipv6
- (package
- (name "thc-ipv6")
- (version "3.2")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/vanhauser-thc/thc-ipv6/"
- "archive/" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "0yh2lpsazmm0pgbmh0dx023w6fss1kdfyr4cq7yw0fac8vkw32d3"))))
- (build-system gnu-build-system)
- (arguments
- `(#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
- #:tests? #f ; No test suite.
- #:phases
- (modify-phases %standard-phases
- (delete 'configure) ; No ./configure script.
- (add-before 'build 'patch-paths
- (lambda _
- (substitute* "Makefile"
- (("/bin/echo") "echo"))
- #t))
- (add-after 'install 'install-more-docs
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (doc (string-append out "/share/thc-ipv6/doc")))
- (install-file "README" doc)
- (install-file "HOWTO-INJECT" doc)
- #t))))))
- ;; TODO Add libnetfilter-queue once packaged.
- (inputs
- `(("libpcap" ,libpcap)
- ("openssl" ,openssl)
- ("perl" ,perl)))
- (home-page "https://github.com/vanhauser-thc/thc-ipv6")
- (synopsis "IPv6 security research toolkit")
- (description "The THC IPv6 Toolkit provides command-line tools and a library
+ (let ((revision "0")
+ (commit "4bb72573e0950ce6f8ca2800a10748477020029e"))
+ (package
+ (name "thc-ipv6")
+ (version (git-version "3.4" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vanhauser-thc/thc-ipv6.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1x5i6vbsddqc2yks7r1a2fw2fk16qxvd6hpzh1lykjfpkal8fdir"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:tests? #f ; No test suite.
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ; No ./configure script.
+ (add-before 'build 'patch-paths
+ (lambda _
+ (substitute* "Makefile"
+ (("/bin/echo") "echo"))
+ #t))
+ (add-after 'install 'install-more-docs
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (doc (string-append out "/share/thc-ipv6/doc")))
+ (install-file "README" doc)
+ (install-file "HOWTO-INJECT" doc)
+ #t))))))
+ ;; TODO Add libnetfilter-queue once packaged.
+ (inputs
+ `(("libpcap" ,libpcap)
+ ("openssl" ,openssl)
+ ("perl" ,perl)))
+ (home-page "https://github.com/vanhauser-thc/thc-ipv6")
+ (synopsis "IPv6 security research toolkit")
+ (description "The THC IPv6 Toolkit provides command-line tools and a library
for researching IPv6 implementations and deployments. It requires Linux 2.6 or
newer and only works on Ethernet network interfaces.")
- ;; AGPL 3 with exception for linking with OpenSSL. See the 'LICENSE' file in
- ;; the source distribution for more information.
- (license license:agpl3)))
+ ;; AGPL 3 with exception for linking with OpenSSL. See the 'LICENSE' file in
+ ;; the source distribution for more information.
+ (license license:agpl3))))
(define-public bmon
(package