aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2016-06-07 21:49:17 +0800
committer宋文武 <iyzsong@gmail.com>2016-06-11 12:53:09 +0800
commit2c1286f48b0a6e09a11cc4d1ea173ea8340625a6 (patch)
tree5b37eff1aaebbb61f035511cde3ca63d1fbf446c /gnu/packages/networking.scm
parent59befb7f3151fc9688f975dedd563b26f2d4cb10 (diff)
downloadguix-2c1286f48b0a6e09a11cc4d1ea173ea8340625a6.tar
guix-2c1286f48b0a6e09a11cc4d1ea173ea8340625a6.tar.gz
gnu: Add librdkafka.
* gnu/packages/networking.scm (librdkafka): New variable.
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index ba8023aeaa..d0062a602a 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -149,6 +149,43 @@ filtering (subscriptions), seamless access to multiple transport protocols and
more.")
(license license:lgpl3+)))
+(define-public librdkafka
+ (package
+ (name "librdkafka")
+ (version "0.9.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/edenhill/librdkafka/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "10ldx7g7ymmg17snzx78vy4n8ma1rjx0agzi34g15j2fk867xmas"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ ;; its custom configure script doesn't understand 'CONFIG_SHELL'.
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ ;; librdkafka++.so lacks RUNPATH for librdkafka.so
+ (setenv "LDFLAGS"
+ (string-append "-Wl,-rpath=" out "/lib"))
+ (zero? (system* "./configure"
+ (string-append "--prefix=" out)))))))))
+ (native-inputs
+ `(("python" ,python-wrapper)))
+ (propagated-inputs
+ `(("zlib" ,zlib))) ; in the Libs.private field of rdkafka.pc
+ (home-page "https://github.com/edenhill/librdkafka")
+ (synopsis "Apache Kafka C/C++ client library")
+ (description
+ "librdkafka is a C library implementation of the Apache Kafka protocol,
+containing both Producer and Consumer support.")
+ (license license:bsd-2)))
+
(define-public libndp
(package
(name "libndp")