aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorfis <ybbs.daans@hotmail.com>2018-04-07 03:44:36 +0800
committerLudovic Courtès <ludo@gnu.org>2018-04-30 23:41:22 +0200
commit1170198d65181ef23bc6a5d130a2b47630cfbb62 (patch)
tree4bfedbb0647515351e7fd0674a097a8a38e509af /gnu/packages/networking.scm
parentb989c3e3760793bf9cb79461b3d03f566e0facc9 (diff)
downloadguix-1170198d65181ef23bc6a5d130a2b47630cfbb62.tar
guix-1170198d65181ef23bc6a5d130a2b47630cfbb62.tar.gz
gnu: Add amule.
* gnu/packages/networking.scm (amule): New public variable. * gnu/packages/patches/amule_crypto-6.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm63
1 files changed, 63 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index b9fb0166f2..f7e5d236db 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -19,6 +19,7 @@
;;; Copyright © 2017 Gábor Boskovits <boskovits@gmail.com>
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2018 Adam Van Ymeren <adam@vany.ca>
+;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -56,6 +57,7 @@
#:use-module (gnu packages check)
#:use-module (gnu packages code)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages crypto)
#:use-module (gnu packages curl)
#:use-module (gnu packages databases)
#:use-module (gnu packages dejagnu)
@@ -66,6 +68,7 @@
#:use-module (gnu packages gnome)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages gtk)
+ #:use-module (gnu packages image)
#:use-module (gnu packages libidn)
#:use-module (gnu packages linux)
#:use-module (gnu packages lua)
@@ -84,6 +87,7 @@
#:use-module (gnu packages tls)
#:use-module (gnu packages valgrind)
#:use-module (gnu packages wm)
+ #:use-module (gnu packages wxwidgets)
#:use-module (gnu packages xml)
#:use-module (ice-9 match))
@@ -1702,3 +1706,62 @@ file for more details.")
;; src/libstrongswan/plugins/blowfish/blowfish_crypter.c
;; src/libstrongswan/plugins/des/des_crypter.c
license:bsd-4))))
+
+(define-public amule
+ (package
+ (name "amule")
+ (version "2.3.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/amule-project/amule/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1wvcj0n9xz03xz5c2xwp6dwfp7sqjhhwbki3m0lwikskpn9lkzk2"))
+ ;; Patch for adopting crypto++ >= 6.0.
+ (patches (search-patches "amule-crypto-6.patch"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'patch-source-shebangs 'autogen
+ (lambda _
+ (invoke "sh" "autogen.sh")
+ #t)))
+ #:configure-flags
+ '("--disable-rpath"
+ "--enable-wxcas"
+ "--enable-cas"
+ "--enable-alc"
+ "--enable-alcc"
+ "--enable-xas"
+ "--enable-amulecmd"
+ "--enable-geoip"
+ "--enable-ccache"
+ "--enable-nls"
+ "--enable-optimize"
+ "--enable-amule-gui"
+ "--enable-amule-daemon"
+ "--enable-webserver"
+ "--with-denoise-level=0")))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("gettext-minimal" ,gettext-minimal)
+ ("perl" ,perl)))
+ (inputs
+ `(("zlib" ,zlib)
+ ("crypto++" ,crypto++)
+ ("libpng" ,libpng)
+ ("wxwidgets-gtk2", wxwidgets-gtk2)))
+ (home-page "http://amule.org/")
+ (synopsis "Peer-to-peer client for the eD2K and Kademlia networks")
+ (description
+ "aMule is an eMule-like client for the eD2k and Kademlia peer-to-peer
+file sharing networks. It includes a graphical user interface (GUI), a daemon
+allowing you to run a client with no graphical interface, and a Web GUI for
+remote access. The @command{amulecmd} command allows you to control aMule
+remotely.")
+ (license license:gpl2+)))