aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-08-11 05:43:04 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-08-11 05:50:37 +0200
commitc7727a8bcd18755580e158aabc8f8565e8d05c7c (patch)
treeaf53aa38aa2e2288a1408e8ac872176ddf7cddb1 /gnu/packages/networking.scm
parente83745a958a2bedeb8c6fa73970531f4a6b9b301 (diff)
downloadguix-c7727a8bcd18755580e158aabc8f8565e8d05c7c.tar
guix-c7727a8bcd18755580e158aabc8f8565e8d05c7c.tar.gz
gnu: Add perl-data-validate-ip.
* gnu/packages/networking.scm (perl-data-validate-ip): New public variable.
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 15e0181d65..1500c4211a 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -815,6 +815,33 @@ attacking, testing, and cracking. All tools are command-line driven, which
allows for heavy scripting.")
(license (list license:gpl2+ license:bsd-3))))
+(define-public perl-data-validate-ip
+ (package
+ (name "perl-data-validate-ip")
+ (version "0.27")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/D/DR/DROLSKY/Data-Validate-IP-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "1mmppyzsh1w2z2h86kvzqxy56wxgs62a3kf8nvcnz76bblir5ap1"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-test-requires" ,perl-test-requires)))
+ (propagated-inputs
+ `(("perl-netaddr-ip" ,perl-netaddr-ip)))
+ (home-page "https://metacpan.org/release/Data-Validate-IP")
+ (synopsis "IPv4 and IPv6 validation methods")
+ (description
+ "This module provides several IP address validation subroutines that both
+validate and untaint their input. This includes both basic validation
+(@code{is_ipv4()} and @code{is_ipv6()}) and special cases like checking whether
+an address belongs to a specific network or whether an address is public or
+private (reserved).")
+ (license license:perl-license)))
+
(define-public perl-net-dns
(package
(name "perl-net-dns")