aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-08-07 11:37:32 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-08-08 02:47:11 +0300
commit277f25ce5af060e2a057f5f43eeea2ae6f4fc5b9 (patch)
treecf77ab7b15f4f131622144bf73112182342756c7 /gnu/packages/networking.scm
parent6d777ff99c7a46516738581732a356a03c3663ff (diff)
downloadguix-277f25ce5af060e2a057f5f43eeea2ae6f4fc5b9.tar
guix-277f25ce5af060e2a057f5f43eeea2ae6f4fc5b9.tar.gz
gnu: Add ubridge.
* gnu/packages/networking.scm (ubridge): New variable.
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 5055f030af..937d6f75ba 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2042,3 +2042,40 @@ SNMP v3 using both IPv4 and IPv6.")
(license:non-copyleft
"http://www.net-snmp.org/about/license.html"
"CMU/UCD copyright notice")))))
+
+(define-public ubridge
+ (package
+ (name "ubridge")
+ (version "0.9.14")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/GNS3/ubridge/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1hivb8wqkk5047bdl2vbsbcvkmam1107hx1ahy4virq2bkqki1fj"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ;no tests
+ #:make-flags '("CC=gcc")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'install 'set-bindir
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((bin (string-append (assoc-ref outputs "out")
+ "/bin")))
+ (mkdir-p bin)
+ (substitute* "Makefile"
+ (("\\$\\(BINDIR\\)") bin)
+ (("\tsetcap cap_net.*$") "")))
+ #t)))))
+ (inputs
+ `(("libpcap" ,libpcap)))
+ (home-page "https://github.com/GNS3/ubridge/")
+ (synopsis "Bridge for UDP tunnels, Ethernet, TAP and VMnet interfaces")
+ (description "uBridge is a simple program to create user-land bridges
+between various technologies. Currently, bridging between UDP tunnels,
+Ethernet and TAP interfaces is supported. Packet capture is also supported.")
+ (license license:gpl3+)))