aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-02-20 12:56:14 +0200
committerEfraim Flashner <efraim@flashner.co.il>2017-02-20 12:56:14 +0200
commitd15432ca9e9359b865aac63ae47863e94bbce0e4 (patch)
treebe4e6f52cb8e31f5b5fad637c95c0a730ea76081 /gnu/packages/networking.scm
parentdef971689052ebc3e0a68684328c28cac35b8596 (diff)
parent3b254d76132627ff62ac5571f4175669164624c5 (diff)
downloadguix-d15432ca9e9359b865aac63ae47863e94bbce0e4.tar
guix-d15432ca9e9359b865aac63ae47863e94bbce0e4.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm59
1 files changed, 59 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index c2df3013c3..a10fbfed92 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -1060,3 +1060,62 @@ suddenly a lot of network traffic, you can fire up NetHogs and immediately see
which PID is causing this. This makes it easy to identify programs that have
gone wild and are suddenly taking up your bandwidth.")
(license license:gpl2+)))
+
+(define-public openvswitch
+ (package
+ (name "openvswitch")
+ (version "2.6.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://openvswitch.org/releases/openvswitch-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "036gq741j9kqsjlp693nff838c9wjd1c56nswl9vyyd1lsmj0yrh"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(;; FIXME: many tests fail with:
+ ;; […]
+ ;; test -e $OVS_RUNDIR/ovs-vswitchd.pid
+ ;; ovs-appctl -t ovs-vswitchd exit
+ ;; hard failure
+ #:tests? #f
+ #:configure-flags
+ '("--enable-shared"
+ "--localstatedir=/var"
+ "--with-dbdir=/var/lib/openvswitch")
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'install
+ (lambda _
+ (zero? (system* "make"
+ ;; Don't try to create directories under /var.
+ "RUNDIR=/tmp"
+ "PKIDIR=/tmp"
+ "LOGDIR=/tmp"
+ "DBDIR=/tmp"
+ "install")))))))
+ (native-inputs
+ `(("perl" ,perl)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python-2)
+ ;; for testing
+ ("util-linux" ,util-linux)))
+ (propagated-inputs
+ `(("python-six" ,python2-six)))
+ (inputs
+ `(("libcap-ng" ,libcap-ng)
+ ("openssl" ,openssl)))
+ (synopsis "Virtual network switch")
+ (home-page "http://www.openvswitch.org/")
+ (description
+ "Open vSwitch is a multilayer virtual switch. It is designed to enable
+massive network automation through programmatic extension, while still
+supporting standard management interfaces and protocols (e.g. NetFlow, sFlow,
+IPFIX, RSPAN, CLI, LACP, 802.1ag).")
+ (license ; see debian/copyright for detail
+ (list license:lgpl2.1 ; xenserver and utilities/bugtool
+ license:gpl2 ; datapath
+ license:bsd-2 license:bsd-3
+ license:asl2.0)))) ; all other