aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/nettle.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-01-04 16:59:46 +0100
committerLudovic Courtès <ludo@gnu.org>2014-01-04 16:59:46 +0100
commit64cc58b24971493cd296eaa9cd78a83c46f1bab3 (patch)
tree9ada86df40e781315c63229e07906dd1aefcbcaa /gnu/packages/nettle.scm
parentcb58dd3479330015cb1417a098100216ba0e7bfa (diff)
downloadguix-64cc58b24971493cd296eaa9cd78a83c46f1bab3.tar
guix-64cc58b24971493cd296eaa9cd78a83c46f1bab3.tar.gz
gnu: nettle: Set the RUNPATH on 'sexp-conv' and other programs.
* gnu/packages/nettle.scm (nettle): Rename 'inputs' to 'native-inputs'. Add 'arguments' field.
Diffstat (limited to 'gnu/packages/nettle.scm')
-rw-r--r--gnu/packages/nettle.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/nettle.scm b/gnu/packages/nettle.scm
index 4e9b3dd7b7..96407837b4 100644
--- a/gnu/packages/nettle.scm
+++ b/gnu/packages/nettle.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -36,7 +36,13 @@
(base32
"0h2vap31yvi1a438d36lg1r1nllfx3y19r4rfxv7slrm6kafnwdw"))))
(build-system gnu-build-system)
- (inputs `(("m4" ,m4)))
+ (arguments
+ ;; 'sexp-conv' and other programs need to have their RUNPATH point to
+ ;; $libdir, which is not the case by default. Work around it.
+ '(#:configure-flags (list (string-append "LDFLAGS=-Wl,-rpath="
+ (assoc-ref %outputs "out")
+ "/lib"))))
+ (native-inputs `(("m4" ,m4)))
(propagated-inputs `(("gmp" ,gmp)))
(home-page "http://www.lysator.liu.se/~nisse/nettle/")
(synopsis "C library for low-level cryptographic functionality")