aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2017-11-21 16:29:59 -0500
committerKei Kebreau <kkebreau@posteo.net>2017-11-21 20:17:26 -0500
commitab2ccf4cf5074f3bd34f7b60dd8ab9dadadfe1c6 (patch)
treed3500e3f2d3567c3ce6a5de6eb62b621d52b0fd4 /gnu/packages/music.scm
parentcd295fbe170a93844f9c42cbfaa0fbe2490b6693 (diff)
downloadguix-ab2ccf4cf5074f3bd34f7b60dd8ab9dadadfe1c6.tar
guix-ab2ccf4cf5074f3bd34f7b60dd8ab9dadadfe1c6.tar.gz
gnu: lmms: Fix build.
* gnu/packages/music.scm (lmms)[arguments]: Add phases "remove-Werror" and "make-manpages-writable".
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm34
1 files changed, 24 insertions, 10 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 77d69df5a4..40eab5ba68 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -3083,16 +3083,30 @@ are a C compiler and glib. Full API documentation and examples are included.")
`(#:tests? #f ; no tests
#:phases
(modify-phases %standard-phases
- (add-before
- 'configure 'set-ldflags
- (lambda* (#:key outputs #:allow-other-keys)
- (setenv "LDFLAGS"
- (string-append
- "-Wl,-rpath=\""
- (assoc-ref outputs "out") "/lib/lmms"
- ":"
- (assoc-ref outputs "out") "/lib/lmms/ladspa"
- "\"")))))))
+ (add-before 'configure 'set-ldflags
+ (lambda* (#:key outputs #:allow-other-keys)
+ (setenv "LDFLAGS"
+ (string-append
+ "-Wl,-rpath=\""
+ (assoc-ref outputs "out") "/lib/lmms"
+ ":"
+ (assoc-ref outputs "out") "/lib/lmms/ladspa"
+ "\""))
+ #t))
+ (add-before 'configure 'remove-Werror
+ (lambda _
+ (substitute* "CMakeLists.txt"
+ (("SET\\(WERROR_FLAGS \"\\$\\{WERROR_FLAGS\\} -Werror")
+ "SET(WERROR_FLAGS \"${WERROR_FLAGS}"))
+ #t))
+ (add-before 'reset-gzip-timestamps 'make-manpages-writable
+ (lambda* (#:key outputs #:allow-other-keys)
+ (map (lambda (file)
+ (make-file-writable file))
+ (find-files (string-append (assoc-ref outputs "out")
+ "/share/man")
+ ".*\\.gz$"))
+ #t)))))
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs