aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-05-23 19:53:55 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:58 +0000
commit3c2943b621c05899aa59f0932b8e1d1053869db1 (patch)
tree22f9feccdedc63c07f972f2de6be05c88f7d2cde /gnu/packages/music.scm
parent5f49430d303a88407c71506f5a7dac8eb8f877cf (diff)
downloadguix-3c2943b621c05899aa59f0932b8e1d1053869db1.tar
guix-3c2943b621c05899aa59f0932b8e1d1053869db1.tar.gz
gnu: build-system/pyproject: Add missing native-inputs.
* gnu/packages/bioinformatics.scm (python-ega-download-client) [native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/databases.scm (datasette)[native-inputs]: Add python-pip. * gnu/packages/django.scm (python-django-localflavor, python-django-contact-form)[native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/graphviz.scm (python-uqbar)[native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/jupyter.scm (python-jupyterlab-server)[native-inputs]: Add python-wheel. (python-nbstripout)[native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/machine-learning.scm (python-captum, python-linear-operator, python-gpytorch)[native-inputs]: Add python-setuptools. * gnu/packages/music.scm (abjad, abjad-ext-rmarkers, abjed-ext-nauert, python-mutagen)[native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/package-management.scm (python-conda-package-handling)[native-inputs]: Add python-setuptools and python-wheel. (conda)[native-inputs]: Add python-wheel. * gnu/packages/python-check.scm (python-pyinstrument, python-pytest-testmon, python-pytest-trio, python-nbval, python-pytest-toolbox)[native-inputs]: Add python-setuptools and python-wheel. (python-nptyping)[native-inputs]: Add python-setuptools. * gnu/packages/python-check.scm (python-dask-expr)[native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/python-web.scm (parfive, python-aioftp, python-hupper, python-sanic, python-mechanicalsoup, python-tinycss, python-aiostream, python-cbor2, gunicorn)[native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/python-xyz.scm (python-apprise, python-jaraco-classes, python-sparse, python-shtab, python-pyan3)[native-inputs]: Add python-setuptools. (python-jupytext, python-orderedmultidict, python-identify, python-nodeenv, python-cfgv, python-zarr, python-multipart, python-nbconvert, python-cram, python-immutables, python-numpydoc, python-cairosvg, python-unidecode, python-black, python-multidict, python-mpv-jsonipc, python-humanize, python-cmd2)[native-inputs]: Add python-setuptools and python-wheel. (python-partd, python-dask, python-zarr)[native-inputs]: Add python-wheel. (python-nbconvert)[propagated-inputs]: Add texlive-etoolbox. Remove duplicate textlive-jknapltx. (python-isort)[native-inputs]: Add python-pip. * gnu/packages/simulation.scm (python-fenics-dijitso)[native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/sphinx.scm (python-pydata-sphinx-theme, python-sphinx-autodoc-typehints)[native-inputs]: Add python-setuptools. * gnu/packages/syndication.scm (tuir)[native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/terminals.scm (python-halo)[native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/time.scm (python-arrow, python-dateutil) [native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/version-control.scm (pre-commit)[native-inputs]: Add python-setuptools and python-wheel. Remove input labels. * gnu/packages/virtualization.scm (python-qemu-qmp, python-transient)[native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/xorg.scm (python-xcffib)[native-inputs]: Add python-setuptools and python-wheel. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Change-Id: Id61cf8cdc47bd4c2871c0a9c8e9a5bfd51157df0
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 78f20166e5..20c6636559 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1811,7 +1811,7 @@ listeners answer questions about music quickly and simply.")
(inputs
(list lilypond))
(native-inputs
- (list python-pytest))
+ (list python-pytest python-setuptools python-wheel))
(propagated-inputs
(list python-quicktions
python-ply
@@ -1843,7 +1843,7 @@ typographic detail of symbols on the page.")
(base32 "1y8s55b4mlsigm0xkk6qjpp08c75rv0swvjp0lj3cs6lgqdjxdjl"))))
(build-system pyproject-build-system)
(native-inputs
- (list lilypond python-pytest))
+ (list lilypond python-pytest python-setuptools python-wheel))
(propagated-inputs
(list abjad))
(home-page "https://abjad.github.io")
@@ -1868,7 +1868,7 @@ and manipulating rhythms such as accelerandi, taleas, and more.")
(base32 "0j4pf4h27jm3df0dn2rwkdx6zqcxvr7pqchbaa9rffz7q4hbakmf"))))
(build-system pyproject-build-system)
(native-inputs
- (list lilypond python-pytest))
+ (list lilypond python-pytest python-setuptools python-wheel))
(propagated-inputs
(list abjad))
(home-page "https://abjad.github.io")
@@ -4074,7 +4074,11 @@ formats, looking up tracks through metadata and audio fingerprints.")
(("( +)@given" all spaces)
(string-append spaces "@settings(deadline=None)\n" all))))))))
(native-inputs
- (list python-pytest python-hypothesis python-flake8))
+ (list python-flake8
+ python-hypothesis
+ python-pytest
+ python-setuptools
+ python-wheel))
(home-page "https://mutagen.readthedocs.io/")
(synopsis "Read and write audio tags")
(description "Mutagen is a Python module to handle audio metadata. It