aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-11-09 22:26:19 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-11-10 20:04:59 +0100
commit28e2f27d5c36c3eed15e2d486dbd75edecbc6146 (patch)
treeb8308ec5aed638450c3bee4a43736d8f5d45165e /gnu/packages/music.scm
parentfbda11b6dc9ee05df1558bd3fbf74bb93549bc0d (diff)
downloadguix-28e2f27d5c36c3eed15e2d486dbd75edecbc6146.tar
guix-28e2f27d5c36c3eed15e2d486dbd75edecbc6146.tar.gz
gnu: amsynth: Find external commands.
* gnu/packages/music.scm (amsynth)[arguments]: Add a ‘patch-file-names’ phase. [inputs]: Add unzip and which.
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm15
1 files changed, 14 insertions, 1 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 3d2133be61..0728144b60 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1804,6 +1804,16 @@ special variant of additive synthesis.")
(base32
"1882pfcmf3rqg3vd4qflzkppcv158d748i603spqjbxqi8z7x7w0"))))
(build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-file-names
+ (lambda _
+ (substitute* "src/GUI/editor_pane.c"
+ (("/usr/bin/unzip") (which "unzip")))
+ (substitute* "src/GUI/GUI.cc"
+ (("/usr/bin/which") (which "which")))
+ #t)))))
(inputs
`(("alsa-lib" ,alsa-lib)
("gtk+" ,gtk+-2)
@@ -1811,7 +1821,10 @@ special variant of additive synthesis.")
("jack" ,jack-1)
("lash" ,lash)
("libsndfile" ,libsndfile)
- ("lv2" ,lv2)))
+ ("lv2" ,lv2)
+ ;; External commands invoked at run time.
+ ("unzip" ,unzip)
+ ("which" ,which)))
(native-inputs
`(("intltool" ,intltool)
("pkg-config" ,pkg-config)))