aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
authorPierre-Antoine Rouby <contact@parouby.fr>2018-05-07 11:47:04 +0200
committerLudovic Courtès <ludo@gnu.org>2018-05-07 11:47:04 +0200
commitb992bfea7491795f540a43bb3b5233d7ebfac8c8 (patch)
treed14abe2fbfbfaa241fa09f122b030b4eb423a7c8 /gnu/packages/messaging.scm
parent31060bff0091ada6e62bdec45ca9401f496b7b6b (diff)
downloadguix-b992bfea7491795f540a43bb3b5233d7ebfac8c8.tar
guix-b992bfea7491795f540a43bb3b5233d7ebfac8c8.tar.gz
gnu: Add bitlbee-discord.
* gnu/packages/messaging.scm (bitlbee-discord): New variable.
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 5b9245697e..b90f95da1c 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -203,6 +203,49 @@ identi.ca and status.net).")
(home-page "http://www.bitlbee.org/")
(license (list license:gpl2+ license:bsd-2))))
+(define-public bitlbee-discord
+ (package
+ (name "bitlbee-discord")
+ (version "0.4.1")
+ (source (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://github.com/sm00th/bitlbee-discord/"
+ "archive/" version ".tar.gz"))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1bwqxlg6fwj3749y7w69n9jwsdzf5nl9xqiszbpv9k8x1422i1y1"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'autogen
+ (lambda _
+ (let ((sh (which "sh")))
+ (substitute* "autogen.sh" (("/bin/sh") sh))
+ (setenv "CONFIG_SHELL" sh)
+ (zero? (system* "./autogen.sh")))))
+ (replace 'configure
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (invoke "./configure"
+ (string-append "--with-plugindir="
+ (assoc-ref outputs "out")
+ "/lib/bitlbee/")))))))
+ (inputs `(("glib" ,glib)))
+ (native-inputs `(("pkg-config" ,pkg-config)
+ ("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("texinfo" ,texinfo)
+ ("libtool" ,libtool)
+ ("bitlbee" ,bitlbee) ;needs bitlbee headers
+ ("bash" ,bash)))
+ (synopsis "Discord plugin for Bitlbee")
+ (description "Bitlbee-discord is a plugin for Bitlbee witch provides
+access to servers running the Discord protocol.")
+ (home-page "https://github.com/sm00th/bitlbee-discord/")
+ (license license:gpl2+)))
+
(define-public hexchat
(package
(name "hexchat")