aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-05-02 21:27:51 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-05-02 23:45:55 +0200
commit8cb3a0cf0aa40fb157474b95413e89635e10c466 (patch)
tree71dcb2e09de2c6a346e3bddb63d3f8848aa6ff81 /gnu/packages/messaging.scm
parent41700efa40dd0247cd907014dc2ecd6594a28e6b (diff)
downloadguix-8cb3a0cf0aa40fb157474b95413e89635e10c466.tar
guix-8cb3a0cf0aa40fb157474b95413e89635e10c466.tar.gz
gnu: znc: Update to 1.7.0.
* gnu/packages/messaging.scm (znc): Update to 1.7.0. [native-inputs]: Replace GOOGLETEST source input with a newer git checkout. [arguments]: Adjust the ‘unpack-googletest’ phase accordingly. Add ‘--with-gmock=...’ to #:configure-flags.
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm32
1 files changed, 24 insertions, 8 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 838199c6e1..64bf3842c2 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -440,32 +440,48 @@ compromised.")
(define-public znc
(package
(name "znc")
- (version "1.6.6")
+ (version "1.7.0")
(source (origin
(method url-fetch)
(uri (string-append "http://znc.in/releases/archive/znc-"
version ".tar.gz"))
(sha256
(base32
- "09cmsnxvi7jg9a0dicf60fxnxdff4aprw7h8vjqlj5ywf6y43f3z"))))
+ "0vxra50418bsjfdpf8vl70fijv8syvasjqdxfyjliff6k91k2zn0"))))
+ ;; TODO: autotools support has been deprecated, and new features like i18n
+ ;; are only supported when building with cmake.
(build-system gnu-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
(add-after 'unpack 'unpack-googletest
(lambda* (#:key inputs #:allow-other-keys)
- (invoke "tar" "xf" (assoc-ref inputs "googletest-source"))
+ (mkdir-p "googletest")
+ (copy-recursively (assoc-ref inputs "googletest-source")
+ "googletest")
#t)))
#:configure-flags '("--enable-python"
"--enable-perl"
"--enable-cyrus"
- ,(string-append "--with-gtest="
- "googletest-release-"
- (package-version googletest)
- "/googletest"))
+ "--with-gmock=googletest/googlemock"
+ "--with-gtest=googletest/googletest")
#:test-target "test"))
(native-inputs
- `(("googletest-source" ,(package-source googletest))
+ `(("googletest-source"
+ ;; ZNC 1.7 needs a newer, unreleased googletest (a release is planned
+ ;; <https://github.com/google/googletest/issues/1583>, so don't update
+ ;; the public GOOGLETEST to an unstable version). The commit is taken
+ ;; from ‘third_party/googletest’ in the ZNC git repository.
+ ,(let ((commit "9737e63c69e94ac5777caa0bc77c77d5206467f3"))
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/google/googletest")
+ (commit commit)))
+ (file-name (git-file-name "googletest-for-znc" commit))
+ (sha256
+ (base32
+ "0ya36n8d62zbxk6p22yffgx43mqhx2fz41gqqwbpdshjryf3wvxj")))))
("pkg-config" ,pkg-config)
("perl" ,perl)
("python" ,python)))