aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2018-05-10 14:41:26 +0200
committerRutger Helling <rhelling@mykolab.com>2018-05-10 14:43:39 +0200
commit8584965b7949cdd7a4cd702b5422474b088beb36 (patch)
treed9330c319e06bc2d9480efdf1788d232c01e6f7f /gnu/packages/messaging.scm
parenta73489e8a74bf5cbd85f0025c28610d098267b53 (diff)
downloadguix-8584965b7949cdd7a4cd702b5422474b088beb36.tar
guix-8584965b7949cdd7a4cd702b5422474b088beb36.tar.gz
gnu: gajim: Fix GtkFileChooserDialog.
* gnu/packages/messaging.scm (gajim)[arguments]: Add 'wrap-program phase to fix GtkFileChooserDialog.
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index b90f95da1c..6efb8121e8 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -627,7 +627,15 @@ was initially a fork of xmpppy, but uses non-blocking sockets.")
(with-directory-excursion icons
(symlink adwaita "Adwaita")
(copy-recursively hicolor "hicolor")))
- #t)))))
+ #t))
+ (add-after 'install-icons 'wrap-program
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (wrap-program (string-append (assoc-ref outputs "out")
+ "/bin/gajim")
+ ;; For GtkFileChooserDialog.
+ `("GSETTINGS_SCHEMA_DIR" =
+ (,(string-append (assoc-ref inputs "gtk+")
+ "/share/glib-2.0/schemas")))))))))
(native-inputs
`(("intltool" ,intltool)
("xorg-server" ,xorg-server)))