aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
authorng0 <ng0@infotropique.org>2017-08-29 13:05:40 +0000
committerChristopher Baines <mail@cbaines.net>2017-09-30 15:22:25 +0100
commit58b2835d03bb6584b90604ce4cea8b407ab6eb76 (patch)
tree6f278ece5528ec5a187c27a9a449563ca41c9717 /gnu/packages/messaging.scm
parent0083a39f1797426bded0f6a191c7ce6acb8a0360 (diff)
downloadguix-58b2835d03bb6584b90604ce4cea8b407ab6eb76.tar
guix-58b2835d03bb6584b90604ce4cea8b407ab6eb76.tar.gz
gnu: pybitmessage: Update to 0.6.2.
* gnu/packages/messaging.scm (pybitmessage): Update to 0.6.2. [build-system]: Change to python-build-system. [arguments]: Remove "fix-makefile" and "wrap" phases. [inputs]: Rename to... [propagated-inputs]: ...this. Add "python2-msgpack" and "python2-pythondialog". [inputs]: Remove "sqlite" and "qt-4". Move "openssl" ... [native-inputs]: ...here. Remove "pkg-config". Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm69
1 files changed, 32 insertions, 37 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 85f86b3f80..8e4b43aaf4 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015, 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2016, 2017 <contact.ng0@cryptolab.net>
+;;; Copyright © 2016, 2017 <ng0@infotropique.org>
;;; Copyright © 2016 Andy Patterson <ajpatter@uwaterloo.ca>
;;; Copyright © 2016, 2017 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2017 Mekeor Melire <mekeor.melire@gmail.com>
@@ -848,7 +848,7 @@ connect with friends and family without anyone else listening in.")
(define-public pybitmessage
(package
(name "pybitmessage")
- (version "0.6.1")
+ (version "0.6.2")
(source
(origin
(method url-fetch)
@@ -857,39 +857,28 @@ connect with friends and family without anyone else listening in.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1ffj7raxpp277kphj98190fxrwfx16vmbspk7k3azg3bh5f5idnf"))))
- (inputs
- `(("python" ,python-2)
- ("python:tk" ,python-2 "tk")
- ("openssl" ,openssl)
- ("sqlite" ,sqlite)
- ("qt" ,qt-4)
+ "1in2mhaxkp2sx8pgvifq9dk1z8b2x3imf1anr0z926vwxwjrf85w"))))
+ (propagated-inputs
+ ;; TODO:
+ ;; Package "pyopencl", required in addition to numpy for OpenCL support.
+ ;; Package "gst123", required in addition to alsa-utils and
+ ;; mpg123 for sound support.
+ `(("python2-msgpack" ,python2-msgpack)
+ ("python2-pythondialog" ,python2-pythondialog)
("python2-pyqt-4" ,python2-pyqt-4)
("python2-sip" ,python2-sip)
("python2-pysqlite" ,python2-pysqlite)
("python2-pyopenssl" ,python2-pyopenssl)))
(native-inputs
- `(("pkg-config" ,pkg-config)))
- (build-system gnu-build-system)
+ `(("openssl" ,openssl)))
+ (build-system python-build-system)
(arguments
- `(#:imported-modules ((guix build python-build-system)
- ,@%gnu-build-system-modules)
- #:make-flags (list (string-append "PREFIX="
- (assoc-ref %outputs "out")))
- #:tests? #f ; no test target
+ `(#:modules ((guix build python-build-system)
+ (guix build utils))
+ #:tests? #f ;no test target
+ #:python ,python-2
#:phases
(modify-phases %standard-phases
- (add-before 'build 'fix-makefile
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "Makefile"
- (("mkdir -p \\$\\{DESTDIR\\}/usr") "")
- (("/usr/local") "")
- (("/usr") "")
- (("#!/bin/sh") (string-append "#!" (which "sh")))
- (("python2") (which "python"))
- (("/opt/openssl-compat-bitcoin/lib/")
- (string-append (assoc-ref inputs "openssl") "/lib/")))
- #t))
(add-after 'unpack 'fix-unmatched-python-shebangs
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "src/bitmessagemain.py"
@@ -923,18 +912,24 @@ connect with friends and family without anyone else listening in.")
(string-append (assoc-ref inputs "openssl")
"/lib/libssl.so")))
#t))
- ;; XXX: Make does not build and install bitmsghash, do it
+ (add-after 'unpack 'noninteractive-build
+ ;; This applies upstream commit 4c597d3f7cf9f83a763472aa165a1a4292019f20
+ (lambda _
+ (substitute* "setup.py"
+ (("except NameError")
+ "except EOFError, NameError"))
+ #t))
+ ;; XXX: python setup.py does not build and install bitmsghash,
+ ;; without it PyBitmessage tries to compile it at first run
+ ;; in the store, which due to obvious reasons fails. Do it
;; and place it in /lib.
- (add-before 'build 'build-and-install-bitmsghash
+ (add-after 'unpack 'build-and-install-bitmsghash
(lambda* (#:key outputs #:allow-other-keys)
- (chdir "src/bitmsghash")
- (system* "make")
- (chdir "../..")
- (install-file "src/bitmsghash/bitmsghash.so"
- (string-append (assoc-ref outputs "out") "/lib"))
- #t))
- (add-after 'install 'wrap
- (@@ (guix build python-build-system) wrap)))))
+ (with-directory-excursion "src/bitmsghash"
+ (system* "make")
+ (install-file "bitmsghash.so"
+ (string-append (assoc-ref outputs "out") "/lib")))
+ #t)))))
(license license:expat)
(description
"Distributed and trustless peer-to-peer communications protocol