aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
authorPierre-Antoine Rouby <contact@parouby.fr>2018-05-07 11:44:00 +0200
committerLudovic Courtès <ludo@gnu.org>2018-05-07 11:45:50 +0200
commit31060bff0091ada6e62bdec45ca9401f496b7b6b (patch)
tree763f82bd910bff81bb8e9cd7a8c6b53780b28879 /gnu/packages/messaging.scm
parentaad16cc1965ab3488449c262455eb29b15c77e95 (diff)
downloadguix-31060bff0091ada6e62bdec45ca9401f496b7b6b.tar
guix-31060bff0091ada6e62bdec45ca9401f496b7b6b.tar.gz
gnu: bitlbee: Install development headers.
* gnu/packages/messaging.scm (bitlbee)[arguments]: Add 'install-lib' phase. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index a3e342ca45..5b9245697e 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2017 Theodoros Foradis <theodoros@foradis.org>
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2018 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2018 Pierre-Antoine Rouby <contact@parouby.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -181,6 +182,9 @@ end-to-end encryption.")
(add-after 'install 'install-etc
(lambda* (#:key (make-flags '()) #:allow-other-keys)
(zero? (apply system* "make" "install-etc" make-flags))))
+ (add-after 'install-etc 'install-lib
+ (lambda* (#:key (make-flags '()) #:allow-other-keys)
+ (zero? (apply system* "make" "install-dev" make-flags))))
(replace 'configure
;; bitlbee's configure script does not tolerate many of the
;; variable settings that Guix would pass to it.