aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-08-04 12:04:09 -0400
committerMark H Weaver <mhw@netris.org>2015-08-04 16:21:17 -0400
commit0a143f673c50b9195be2d6229d161e56d205efc1 (patch)
tree299fb87829f01863798c52a834d8af309231224d /gnu/packages/messaging.scm
parentb1a2bc895a3c12a4a668a04aec3e0e32c5ec0857 (diff)
downloadguix-0a143f673c50b9195be2d6229d161e56d205efc1.tar
guix-0a143f673c50b9195be2d6229d161e56d205efc1.tar.gz
gnu: Add pidgin-otr.
* gnu/packages/messaging.scm (pidgin-otr): New variable.
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index bb75dd43b6..45110f5342 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -319,4 +319,42 @@ chat protocols.")
"file://libpurple/protocols/zephyr/mit-sipb-copyright.h"
"See libpurple/protocols/zephyr/mit-sipb-copyright.h in the distribution.")))))
+(define-public pidgin-otr
+ (package
+ (name "pidgin-otr")
+ (version "4.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://otr.cypherpunks.ca/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "02pkkf86fh5jvzsdn9y78impsgzj1n0p81kc2girvk3vq941yy0v"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("intltool" ,intltool)))
+ (inputs
+ `(("pidgin" ,pidgin)
+ ("libotr" ,libotr)
+ ("libgpg-error" ,libgpg-error)
+ ("libgcrypt" ,libgcrypt)
+ ("glib" ,glib)
+ ("gtk+" ,gtk+-2)))
+ (home-page "https://otr.cypherpunks.ca/")
+ (synopsis "Off-the-Record Messaging plugin for Pidgin")
+ (description
+ "Pidgin-OTR is a plugin that adds support for OTR to the Pidgin instant
+messaging client. OTR (Off-the-Record) Messaging allows you to have private
+conversations over instant messaging by providing: (1) Encryption: No one else
+can read your instant messages. (2) Authentication: You are assured the
+correspondent is who you think it is. (3) Deniability: The messages you send
+do not have digital signatures that are checkable by a third party. Anyone
+can forge messages after a conversation to make them look like they came from
+you. However, during a conversation, your correspondent is assured the
+messages he sees are authentic and unmodified. (4) Perfect forward secrecy:
+If you lose control of your private keys, no previous conversation is
+compromised.")
+ (license gpl2)))
+
;;; messaging.scm ends here