aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorThomas Danckaert <thomas.danckaert@gmail.com>2016-10-19 11:44:33 +0200
committerLudovic Courtès <ludo@gnu.org>2016-10-24 23:14:52 +0200
commitd91025e3d0f7a30b38798bc4ef9c0f96d3f85db7 (patch)
treebca3994e783b4b8541b93ac22d952a20ea79b9ea /gnu/packages/maths.scm
parentd3c4f3bb00b9e04b7bdb2847f21e33292b103c21 (diff)
downloadguix-d91025e3d0f7a30b38798bc4ef9c0f96d3f85db7.tar
guix-d91025e3d0f7a30b38798bc4ef9c0f96d3f85db7.tar.gz
gnu: Add coda.
* gnu/packages/maths.scm (coda): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 0cdf4f74b5..2928cb63a3 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -113,6 +113,37 @@ interactive dialogs to guide them.")
(license license:gpl3+)
(home-page "http://www.gnu.org/software/c-graph/")))
+(define-public coda
+ (package
+ (name "coda")
+ (version "2.17.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/stcorp/coda/releases/download/"
+ version "/coda-" version ".tar.gz"))
+ (sha256
+ (base32 "04b9l3wzcix0mnfq77mwnil6cbr8h2mki8myvy0lzn236qcwaq1h"))))
+ (native-inputs
+ `(("fortran" ,gfortran)
+ ("python" ,python)
+ ("python-numpy" ,python-numpy)))
+ (inputs
+ `(("zlib" ,zlib)
+ ("hdf4" ,hdf4-alt)
+ ("hdf5" ,hdf5)))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags '("--with-hdf4" "--with-hdf5" "--enable-python")))
+ (synopsis "A common interface to various earth observation data formats")
+ (description
+ "The Common Data Access toolbox (CODA) provides a set of interfaces for
+reading remote sensing data from earth observation data files. It consists of
+command line applications and interfaces to the C, Fortran, Python, and Java
+programming languages.")
+ (home-page "https://stcorp.nl/coda")
+ (license license:gpl2+)))
+
(define-public units
(package
(name "units")