aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2020-09-17 11:47:55 -0400
committerMathieu Othacehe <othacehe@gnu.org>2020-09-18 08:57:48 +0200
commitc59e9f0a03241ef3c7b8042054fd54e327f7539a (patch)
treed7f146e63bb84e1789db37a6a767b28f0217449e /gnu/packages/maths.scm
parent98b89f432103b66efacee0bcba41a94148b8e870 (diff)
downloadguix-c59e9f0a03241ef3c7b8042054fd54e327f7539a.tar
guix-c59e9f0a03241ef3c7b8042054fd54e327f7539a.tar.gz
gnu: openblas: Update to 0.3.10.
* gnu/packages/maths.scm (openblas): Update to 0.3.10. [source]: Fetch from github. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index ce393cba80..dd4d34615b 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -40,6 +40,7 @@
;;; Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2020 Greg Hogan <code@greghogan.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3609,16 +3610,17 @@ parts of it.")
(define-public openblas
(package
(name "openblas")
- (version "0.3.9")
+ (version "0.3.10")
(source
(origin
- (method url-fetch)
- (uri (string-append "mirror://sourceforge/openblas/v" version "/OpenBLAS%20"
- version "%20version.tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/xianyi/OpenBLAS")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "14iz9xnrb9xiwgj84j94mc74gg0zn2vsy9fmsijxxma1n7dck4w3"))))
+ "174id98ga82bhz2v7sy9yj6pqy0h0088p3mkdikip69p9rh3d17b"))))
(build-system gnu-build-system)
(arguments
`(#:test-target "test"