aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-11-17 21:18:43 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-11-20 00:57:48 +0100
commitfb525bfd83ac1721e138420a01e7075c25b137c4 (patch)
treec62eb38b4637f721c27e3a55227a76ac95b18722 /gnu/packages/maths.scm
parentcc661cb348818da41e7f6ef3dc86bbb66f1e14a1 (diff)
downloadguix-fb525bfd83ac1721e138420a01e7075c25b137c4.tar
guix-fb525bfd83ac1721e138420a01e7075c25b137c4.tar.gz
gnu: z3: Fetch source using git.
* gnu/packages/maths.scm (z3)[source]: Change to GIT-FETCH.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 82abc22994..22451c3da1 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -3947,14 +3947,14 @@ as equations, scalars, vectors, and matrices.")
(package
(name "z3")
(version "4.5.0")
+ (home-page "https://github.com/Z3Prover/z3")
(source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/Z3Prover/z3/archive/z3-"
- version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference (url home-page)
+ (commit (string-append "z3-" version))))
(sha256
(base32
- "032a5lvji2liwmc25jv52bdrhimqflvqbpg77ccaq1jykhiivbmf"))))
+ "0ssp190ksak93hiz61z90x6hy9hcw1ywp8b2dzmbhn6fbd4bnxzp"))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags
@@ -3983,7 +3983,6 @@ as equations, scalars, vectors, and matrices.")
(synopsis "Theorem prover")
(description "Z3 is a theorem prover and @dfn{satisfiability modulo
theories} (SMT) solver. It provides a C/C++ API, as well as Python bindings.")
- (home-page "https://github.com/Z3Prover/z3")
(license license:expat)))
(define-public cubicle