aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-09-26 01:11:32 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-09-26 01:11:32 +0200
commit6a0427af6cc3d52c0efc09262e90c1858ae6f40e (patch)
treeafedf3a5728dfac46c20aed448326debccf96562 /gnu/packages/maths.scm
parent985d542e028517b2888fa61831233a2b60dc7d48 (diff)
parent3b97a1779f3b65d582b8edc8c154b6414314b946 (diff)
downloadguix-6a0427af6cc3d52c0efc09262e90c1858ae6f40e.tar
guix-6a0427af6cc3d52c0efc09262e90c1858ae6f40e.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm21
1 files changed, 17 insertions, 4 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index b00d1aa8f1..b8c1c8f951 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -814,8 +814,11 @@ incompatible with HDF5.")
(mkdir-p flib)
(mkdir-p finc)
(mkdir-p fex)
- (rename-file (string-append bin "/h5fc")
- (string-append fbin "/h5fc"))
+ ;; Note: When built with --enable-parallel, the 'h5fc' file
+ ;; doesn't exist, hence this condition.
+ (when (file-exists? (string-append bin "/h5fc"))
+ (rename-file (string-append bin "/h5fc")
+ (string-append fbin "/h5fc")))
(for-each (lambda (file)
(rename-file file
(string-append flib "/" (basename file))))
@@ -1034,10 +1037,13 @@ Swath).")
`(("mpi" ,openmpi)
,@(package-inputs hdf5)))
(arguments
- (substitute-keyword-arguments `(#:configure-flags '("--enable-parallel")
- ,@(package-arguments hdf5))
+ (substitute-keyword-arguments (package-arguments hdf5)
+ ((#:configure-flags flags)
+ ``("--enable-parallel" ,@(delete "--enable-cxx" ,flags)))
((#:phases phases)
`(modify-phases ,phases
+ (add-after 'build 'mpi-setup
+ ,%openmpi-setup)
(add-before 'check 'patch-tests
(lambda _
;; OpenMPI's mpirun will exit with non-zero status if it
@@ -1396,6 +1402,13 @@ can solve two kinds of problems:
("less" ,less)
("ghostscript" ,ghostscript)
("gnuplot" ,gnuplot)))
+ ;; Octave code uses this variable to detect directories holding multiple CA
+ ;; certificates to verify peers with. This is required for the networking
+ ;; functions that require encryption to work properly.
+ (native-search-paths
+ (list (search-path-specification
+ (variable "CURLOPT_CAPATH")
+ (files '("etc/ssl/certs")))))
(arguments
`(#:configure-flags
(list (string-append "--with-shell="