aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-12-31 14:10:25 +0200
committerEfraim Flashner <efraim@flashner.co.il>2017-12-31 14:10:25 +0200
commit23de2e1d5f8f7548e6f73085de23d9964774edbf (patch)
treefab69d4bb55f275f14012a724b7cb14bd307b57f /gnu/packages/maths.scm
parentec6ba5c1fe9308cbc18f06c99adcfe0d13396a18 (diff)
parent1c27f72fc2770d68243dd95b7c05adc3b2b02ea4 (diff)
downloadguix-23de2e1d5f8f7548e6f73085de23d9964774edbf.tar
guix-23de2e1d5f8f7548e6f73085de23d9964774edbf.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm20
1 files changed, 15 insertions, 5 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 11213bea94..02c0e6988f 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -21,6 +21,7 @@
;;; Copyright © 2017 Theodoros Foradis <theodoros@foradis.org>
;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017 Dave Love <me@fx@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1878,7 +1879,7 @@ sparse system of linear equations A x = b using Guassian elimination.")
(build-system r-build-system)
(native-inputs
`(("gfortran" ,gfortran)))
- (home-page "http://cran.r-project.org/web/packages/quadprog")
+ (home-page "https://cran.r-project.org/web/packages/quadprog")
(synopsis "Functions to solve quadratic programming problems")
(description
"This package contains routines and documentation for solving quadratic
@@ -1897,7 +1898,7 @@ programming problems.")
(build-system r-build-system)
(propagated-inputs
`(("r-quadprog" ,r-quadprog)))
- (home-page "http://cran.r-project.org/web/packages/pracma")
+ (home-page "https://cran.r-project.org/web/packages/pracma")
(synopsis "Practical numerical math functions")
(description "This package provides functions for numerical analysis and
linear algebra, numerical optimization, differential equations, plus some
@@ -2634,7 +2635,6 @@ parts of it.")
#:make-flags
(list (string-append "PREFIX=" (assoc-ref %outputs "out"))
"SHELL=bash"
- "NO_LAPACK=1"
;; Build the library for all supported CPUs. This allows
;; switching CPU targets at runtime with the environment variable
;; OPENBLAS_CORETYPE=<type>, where "type" is a supported CPU type.
@@ -2655,11 +2655,21 @@ parts of it.")
'("TARGET=ARMV8"))
(else '()))))
;; no configure script
- #:phases (alist-delete 'configure %standard-phases)))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'build 'set-extralib
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; Get libgfortran found when building in utest.
+ (setenv "FEXTRALIB"
+ (string-append "-L" (assoc-ref inputs "fortran-lib")
+ "/lib"))
+ #t)))))
(inputs
- `(("fortran" ,gfortran)))
+ `(("fortran-lib" ,gfortran "lib")))
(native-inputs
`(("cunit" ,cunit)
+ ("fortran" ,gfortran)
("perl" ,perl)))
(home-page "http://www.openblas.net/")
(synopsis "Optimized BLAS library based on GotoBLAS")