aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/mate.scm
diff options
context:
space:
mode:
authorFabian Harfert <fhmgufs@web.de>2016-02-10 00:00:20 +0100
committerEfraim Flashner <efraim@flashner.co.il>2016-02-17 12:14:02 +0200
commitbb2fe79e6e205aa83bc5a94a77e61267b342dccf (patch)
tree4e0ad6a540eec7cab4d420a38cccdb078f669a34 /gnu/packages/mate.scm
parent44a2bdf8e7b1d4a30463ac58c730fdfcd925d3aa (diff)
downloadguix-bb2fe79e6e205aa83bc5a94a77e61267b342dccf.tar
guix-bb2fe79e6e205aa83bc5a94a77e61267b342dccf.tar.gz
gnu: Add mate-icon-theme.
* gnu/packages/mate.scm: New file. * gnu-system.am (GNU_SYSTEM_MODULES): Add it. * gnu/packages/mate.scm (mate-icon-theme): New variable.
Diffstat (limited to 'gnu/packages/mate.scm')
-rw-r--r--gnu/packages/mate.scm53
1 files changed, 53 insertions, 0 deletions
diff --git a/gnu/packages/mate.scm b/gnu/packages/mate.scm
new file mode 100644
index 0000000000..d8242d69cb
--- /dev/null
+++ b/gnu/packages/mate.scm
@@ -0,0 +1,53 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2016 Fabian Harfert <fhmgufs@web.de>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages mate)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix utils)
+ #:use-module (guix build-system gnu)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages glib)
+ #:use-module (gnu packages gtk)
+ #:use-module (gnu packages gnome))
+
+(define-public mate-icon-theme
+ (package
+ (name "mate-icon-theme")
+ (version "1.12.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://pub.mate-desktop.org/releases/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0d91rvl9rw3xl8hmdcbb6xvi880kfmh2ra5chhrjimrjqgl57qkp"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("intltool" ,intltool)
+ ("gtk+" ,gtk+)
+ ("icon-naming-utils" ,icon-naming-utils)))
+ (home-page "http://mate-desktop.org/")
+ (synopsis "The MATE desktop environment icon theme")
+ (description
+ "This package contains the default icon theme used by the MATE desktop.")
+ (license license:lgpl3+)))