aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/mate.scm
diff options
context:
space:
mode:
authorng0 <ng0@infotropique.org>2017-12-30 22:50:50 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2017-12-30 22:55:25 +0100
commita1eef8257eb20fcba17266512201ecef1877ad0e (patch)
tree2a0d0213af2c2b9fee42303409196d4955b648fc /gnu/packages/mate.scm
parent446131be50b8a50d74adf3cea56c4dedc2f7c87d (diff)
downloadguix-a1eef8257eb20fcba17266512201ecef1877ad0e.tar
guix-a1eef8257eb20fcba17266512201ecef1877ad0e.tar.gz
gnu: Add pluma.
* gnu/packages/mate.scm (pluma): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/mate.scm')
-rw-r--r--gnu/packages/mate.scm53
1 files changed, 53 insertions, 0 deletions
diff --git a/gnu/packages/mate.scm b/gnu/packages/mate.scm
index 8f6a84a4fa..820dcb8e42 100644
--- a/gnu/packages/mate.scm
+++ b/gnu/packages/mate.scm
@@ -35,6 +35,7 @@
#:use-module (gnu packages djvu)
#:use-module (gnu packages docbook)
#:use-module (gnu packages documentation)
+ #:use-module (gnu packages enchant)
#:use-module (gnu packages file)
#:use-module (gnu packages fonts)
#:use-module (gnu packages fontutils)
@@ -48,6 +49,7 @@
#:use-module (gnu packages gtk)
#:use-module (gnu packages image)
#:use-module (gnu packages imagemagick)
+ #:use-module (gnu packages iso-codes)
#:use-module (gnu packages javascript)
#:use-module (gnu packages libcanberra)
#:use-module (gnu packages linux)
@@ -1390,6 +1392,57 @@ can be used as backgrounds in the MATE Desktop environment.")
"Engrampa is the archive manager for the MATE Desktop.")
(license license:gpl2)))
+(define-public pluma
+ (package
+ (name "pluma")
+ (version "1.18.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://pub.mate-desktop.org/releases/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1z0938yiygxipj2a77n9dv8v4253snrc5gbbnarcnim9xba2j3zz"))))
+ (build-system glib-or-gtk-build-system)
+ (arguments
+ `(; Tests can not succeed.
+ ;; https://github.com/mate-desktop/mate-text-editor/issues/33
+ #:tests? #f))
+ (native-inputs
+ `(("gettext" ,gettext-minimal)
+ ("gtk-doc" ,gtk-doc)
+ ("gobject-introspection" ,gobject-introspection)
+ ("intltool" ,intltool)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)
+ ("yelp-tools" ,yelp-tools)))
+ (inputs
+ `(("atk" ,atk)
+ ("cairo" ,cairo)
+ ("enchant" ,enchant)
+ ("glib" ,glib)
+ ("gtk+" ,gtk+)
+ ("gtksourceview" ,gtksourceview)
+ ("gdk-pixbuf" ,gdk-pixbuf)
+ ("iso-codes" ,iso-codes)
+ ("libcanberra" ,libcanberra)
+ ("libx11" ,libx11)
+ ("libsm" ,libsm)
+ ("libpeas" ,libpeas)
+ ("libxml2" ,libxml2)
+ ("libice" ,libice)
+ ("packagekit" ,packagekit)
+ ("pango" ,pango)
+ ("python-2" ,python-2)
+ ("scrollkeeper" ,scrollkeeper)))
+ (home-page "https://mate-desktop.org/")
+ (synopsis "Text Editor for MATE")
+ (description
+ "Pluma is the text editor for the MATE Desktop.")
+ (license license:gpl2)))
+
(define-public mate
(package
(name "mate")