aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/mate.scm
diff options
context:
space:
mode:
authorng0 <ng0@infotropique.org>2017-08-06 18:03:17 +0000
committerEfraim Flashner <efraim@flashner.co.il>2017-09-12 09:55:20 +0300
commit4d26a340b58dfd73e0d87d2a4f37e185e11ef8f1 (patch)
tree24fd9ba7f159888be75e27289f616bfc6d9c6850 /gnu/packages/mate.scm
parent17df429ce66044e5f18a1d490cedf9a4a08da82f (diff)
downloadguix-4d26a340b58dfd73e0d87d2a4f37e185e11ef8f1.tar
guix-4d26a340b58dfd73e0d87d2a4f37e185e11ef8f1.tar.gz
gnu: Add marco.
* gnu/packages/mate.scm (marco): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/mate.scm')
-rw-r--r--gnu/packages/mate.scm52
1 files changed, 52 insertions, 0 deletions
diff --git a/gnu/packages/mate.scm b/gnu/packages/mate.scm
index 18b7371d3c..600f977bac 100644
--- a/gnu/packages/mate.scm
+++ b/gnu/packages/mate.scm
@@ -28,6 +28,7 @@
#:use-module (gnu packages)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages freedesktop)
+ #:use-module (gnu packages libcanberra)
#:use-module (gnu packages glib)
#:use-module (gnu packages gtk)
#:use-module (gnu packages gnome)
@@ -304,3 +305,54 @@ icons on the MATE desktop. It works on local and remote filesystems.")
;; does not exist. It is safe to assume that this is of no concern
;; for us.
(license license:gpl2+)))
+
+(define-public marco
+ (package
+ (name "marco")
+ (version "1.18.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://pub.mate-desktop.org/releases/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0lwbp9wyd66hl5d7g272l8g3k1pb9s4s2p9fb04750a58w87d8k5"))))
+ (build-system glib-or-gtk-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("intltool" ,intltool)
+ ("itstool" ,itstool)
+ ("glib" ,glib)
+ ("gobject-introspection" ,gobject-introspection)
+ ("libxft" ,libxft)
+ ("libxml2" ,libxml2)
+ ("zenity" ,zenity)))
+ (inputs
+ `(("gtk+" ,gtk+)
+ ("libcanberra" ,libcanberra)
+ ("libgtop" ,libgtop)
+ ("libice" ,libice)
+ ("libsm" ,libsm)
+ ("libx11" ,libx11)
+ ("libxcomposite" ,libxcomposite)
+ ("libxcursor" ,libxcursor)
+ ("libxdamage" ,libxdamage)
+ ("libxext" ,libxext)
+ ("libxfixes" ,libxfixes)
+ ("libxinerama" ,libxinerama)
+ ("libxrandr" ,libxrandr)
+ ("libxrender" ,libxrender)
+ ("mate-desktop" ,mate-desktop)
+ ("pango" ,pango)
+ ("startup-notification" ,startup-notification)))
+ (home-page "https://mate-desktop.org/")
+ (synopsis "Window manager for the MATE desktop")
+ (description
+ "Marco is a minimal X window manager that uses GTK+ for drawing
+window frames. It is aimed at non-technical users and is designed to integrate
+well with the MATE desktop. It lacks some features that may be expected by
+some users; these users may want to investigate other available window managers
+for use with MATE or as a standalone window manager.")
+ (license license:gpl2+)))