aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/machine-learning.scm
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2017-03-17 21:24:13 +1000
committerBen Woodcroft <donttrustben@gmail.com>2017-03-17 21:43:27 +1000
commit0a3063d64077f164670b8e7d0bc58b5f40ffeb12 (patch)
treec94302880b4ffd7b8ef31ee1e8018d0b0a2a50db /gnu/packages/machine-learning.scm
parentba1be533ad4db5a032559fc1a6f501b5de381088 (diff)
downloadguix-0a3063d64077f164670b8e7d0bc58b5f40ffeb12.tar
guix-0a3063d64077f164670b8e7d0bc58b5f40ffeb12.tar.gz
gnu: Add ocaml-mcl.
* gnu/packages/machine-learning.scm (ocaml-mcl): New variable.
Diffstat (limited to 'gnu/packages/machine-learning.scm')
-rw-r--r--gnu/packages/machine-learning.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 5379893b76..30f005a331 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -26,6 +26,7 @@
#:use-module (guix svn-download)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system ocaml)
#:use-module (guix build-system r)
#:use-module (gnu packages)
#:use-module (gnu packages autotools)
@@ -35,6 +36,7 @@
#:use-module (gnu packages gcc)
#:use-module (gnu packages image)
#:use-module (gnu packages maths)
+ #:use-module (gnu packages ocaml)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
@@ -239,6 +241,39 @@ networks) based on simulation of (stochastic) flow in graphs.")
;; http://listserver.ebi.ac.uk/pipermail/mcl-users/2016/000376.html
(license license:gpl3)))
+(define-public ocaml-mcl
+ (package
+ (name "ocaml-mcl")
+ (version "12-068oasis4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/fhcrc/mcl/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1l5jbhwjpsj38x8b9698hfpkv75h8hn3kj0gihjhn8ym2cwwv110"))))
+ (build-system ocaml-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'patch-paths
+ (lambda _
+ (substitute* "configure"
+ (("SHELL = /bin/sh") (string-append "SHELL = "(which "sh"))))
+ (substitute* "setup.ml"
+ (("LDFLAGS=-fPIC")
+ (string-append "LDFLAGS=-fPIC\"; \"SHELL=" (which "sh"))))
+ #t)))))
+ (home-page "https://github.com/fhcrc/mcl")
+ (synopsis "OCaml wrappers around MCL")
+ (description
+ "This package provides OCaml bindings for the MCL graph clustering
+algorithm.")
+ (license license:gpl3)))
+
(define-public randomjungle
(package
(name "randomjungle")