aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/lynx.scm
diff options
context:
space:
mode:
authorKei Kebreau <kei@openmailbox.org>2017-05-08 15:16:24 -0400
committerKei Kebreau <kei@openmailbox.org>2017-05-08 15:16:24 -0400
commitc5196ac7ee668a65c0cfda25ce354b826b15435c (patch)
treecfc5f27d49ca60ddc0ad0c776843fc543d64f705 /gnu/packages/lynx.scm
parent8bdc36d4bd5d38a5e595c9c51e61bad4caf291e0 (diff)
downloadguix-c5196ac7ee668a65c0cfda25ce354b826b15435c.tar
guix-c5196ac7ee668a65c0cfda25ce354b826b15435c.tar.gz
gnu: Move lynx to web-browsers.scm.
* gnu/packages/lynx.scm: Remove file and move lynx... * gnu/packages/web-browsers.scm: ...here. * gnu/packages/man.scm (define-module): Remove unused module import of (gnu packages lynx). * gnu/packages/ocaml.scm (define-module): Adjust module import to use (gnu packages web-browsers). * gnu/local.mk (GNU_SYSTEM_MODULES): Remove lynx.scm.
Diffstat (limited to 'gnu/packages/lynx.scm')
-rw-r--r--gnu/packages/lynx.scm91
1 files changed, 0 insertions, 91 deletions
diff --git a/gnu/packages/lynx.scm b/gnu/packages/lynx.scm
deleted file mode 100644
index b212dca388..0000000000
--- a/gnu/packages/lynx.scm
+++ /dev/null
@@ -1,91 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2016 Kei Kebreau <kei@openmailbox.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu packages lynx)
- #:use-module ((guix licenses) #:select (gpl2))
- #:use-module (guix packages)
- #:use-module (guix download)
- #:use-module (guix build-system gnu)
- #:use-module (gnu packages pkg-config)
- #:use-module (gnu packages perl)
- #:use-module (gnu packages ncurses)
- #:use-module (gnu packages libidn)
- #:use-module (gnu packages gnupg)
- #:use-module (gnu packages tls)
- #:use-module (gnu packages zip)
- #:use-module (gnu packages compression))
-
-(define-public lynx
- (package
- (name "lynx")
- (version "2.8.9dev.11")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "http://invisible-mirror.net/archives/lynx/tarballs"
- "/lynx" version ".tar.bz2"))
- (sha256
- (base32
- "1cqm1i7d209brkrpzaqqf2x951ra3l67dw8x9yg10vz7rpr9441a"))))
- (build-system gnu-build-system)
- (native-inputs `(("pkg-config" ,pkg-config)
- ("perl" ,perl)))
- (inputs `(("ncurses" ,ncurses)
- ("libidn" ,libidn)
- ("gnutls" ,gnutls)
- ("libgcrypt" ,libgcrypt)
- ("unzip" ,unzip)
- ("zlib" ,zlib)
- ("gzip" ,gzip)
- ("bzip2" ,bzip2)))
- (arguments
- `(#:configure-flags
- (let ((gnutls (assoc-ref %build-inputs "gnutls")))
- `("--with-pkg-config"
- "--with-screen=ncurses"
- "--with-zlib"
- "--with-bzlib"
- ,(string-append "--with-gnutls=" gnutls)
- ;; "--with-socks5" ; XXX TODO
- "--enable-widec"
- "--enable-ascii-ctypes"
- "--enable-local-docs"
- "--enable-htmlized-cfg"
- "--enable-gzip-help"
- "--enable-nls"
- "--enable-ipv6"))
- #:tests? #f ; no check target
- #:phases (alist-replace
- 'install
- (lambda* (#:key (make-flags '()) #:allow-other-keys)
- (zero? (apply system* "make" "install-full" make-flags)))
- %standard-phases)))
- (synopsis "Text Web Browser")
- (description
- "Lynx is a fully-featured World Wide Web (WWW) client for users running
-cursor-addressable, character-cell display devices. It will display Hypertext
-Markup Language (HTML) documents containing links to files on the local
-system, as well as files on remote systems running http, gopher, ftp, wais,
-nntp, finger, or cso/ph/qi servers. Lynx can be used to access information on
-the WWW, or to build information systems intended primarily for local
-access.")
- (home-page "http://lynx.isc.org/")
- (license gpl2)))
-
-;;; lynx.scm ends here