aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/lxqt.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-07-24 23:05:02 +0200
committerAndreas Enge <andreas@enge.fr>2015-07-24 23:10:54 +0200
commit6bb5a8a1c1400279a1f84873d4e3f40ae554c7a5 (patch)
treea57f54812e3151ce4915b6bb9a3078851aa5f8c5 /gnu/packages/lxqt.scm
parent4a8276704fb43d573b90ba19cf7b1b91978cfd18 (diff)
downloadguix-6bb5a8a1c1400279a1f84873d4e3f40ae554c7a5.tar
guix-6bb5a8a1c1400279a1f84873d4e3f40ae554c7a5.tar.gz
gnu: Add liblxqt.
* gnu/packages/lxqt.scm (liblxqt): New variable.
Diffstat (limited to 'gnu/packages/lxqt.scm')
-rw-r--r--gnu/packages/lxqt.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index cb6cb64e0b..2c4f21f4f0 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -23,6 +23,7 @@
#:use-module (guix packages)
#:use-module (guix utils)
#:use-module (guix build-system cmake)
+ #:use-module (gnu packages kde-frameworks)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages qt))
@@ -56,3 +57,32 @@
(description "Libqtxdg implements the freedesktop.org xdg specifications
in Qt.")
(license lgpl2.1+)))
+
+(define-public liblxqt
+ (package
+ (name "liblxqt")
+ (version "0.9.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://github.com/lxde/" name "/releases/download/"
+ version "/" name "-" version ".tar.xz"))
+ (uri
+ (string-append "https://github.com/lxde/" name "/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz")) (sha256
+ (base32
+ "0mbl3qc0yfgfsndqrw8vg8k5irsy0pg2wrad8nwv0aphphd4n7rg"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f))
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("kwindowsystem" ,kwindowsystem)
+ ("libqtxdg" ,libqtxdg)))
+ (home-page "http://lxqt.org/")
+ (synopsis "Core utility library for all LXQt components")
+ (description "liblxqt provides the basic libraries shared by the
+components of the LxQt desktop environment.")
+ (license lgpl2.1+)))