aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/lxqt.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-10-03 21:20:41 +0200
committerAndreas Enge <andreas@enge.fr>2015-10-03 21:20:41 +0200
commit54033a4db61fc76b15f0654ad4b33ac0d7d6a47f (patch)
tree8a36dc2f733164bb87977ed04f7c9208a041735b /gnu/packages/lxqt.scm
parentcfa2e4ad4097947ec393888dc4a95322e1364ba9 (diff)
downloadguix-54033a4db61fc76b15f0654ad4b33ac0d7d6a47f.tar
guix-54033a4db61fc76b15f0654ad4b33ac0d7d6a47f.tar.gz
gnu: Add lxqt-session.
* gnu/packages/lxqt.scm (lxqt-session): New variable.
Diffstat (limited to 'gnu/packages/lxqt.scm')
-rw-r--r--gnu/packages/lxqt.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index 518c63e481..e6f8753aa0 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -133,3 +133,45 @@ components of the LxQt desktop environment.")
(themes, icons, configuration files etc.) for the LXQt
desktop environment.")
(license lgpl2.1+)))
+
+(define-public lxqt-session
+ (package
+ (name "lxqt-session")
+ (version "0.9.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "http://downloads.lxqt.org/lxqt/" version "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "01hxand1gqbcaw14lh7z6w5zssgfaffcjncv752c2c7272wzyhy5"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("kwindowsystem" ,kwindowsystem)
+ ("liblxqt" ,liblxqt)
+ ("libqtxdg" ,libqtxdg)))
+ (arguments
+ `(#:tests? #f ; no check target
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'fix-installation-paths
+ (lambda _
+ ;; The variable LXQT_TRANSLATIONS_DIR is set in
+ ;; liblxqt-0.9.0/share/cmake/lxqt/lxqt-config.cmake
+ ;; to the liblxqt installation directory, followed by
+ ;; "/share/lxqt/translations".
+ ;; We need to have it point to the current installation
+ ;; directory instead.
+ (substitute* '("lxqt-session/CMakeLists.txt"
+ "lxqt-config-session/CMakeLists.txt")
+ (("\\$\\{LXQT_TRANSLATIONS_DIR\\}")
+ "${CMAKE_INSTALL_PREFIX}/share/lxqt/translations")))))))
+ (home-page "http://lxqt.org/")
+ (synopsis "Session manager for LXQt")
+ (description "lxqt-session provides the standard session manager
+for the LXQt desktop environment.")
+ (license lgpl2.1+)))