aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/lxqt.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-07-27 22:54:58 +0200
committerAndreas Enge <andreas@enge.fr>2015-07-27 22:54:58 +0200
commit44a477e1ac8efe166f3f4d2f56e2ec828a3521e1 (patch)
tree9bcf025cb24e3d9dee7e167fe4ad82ae866987d6 /gnu/packages/lxqt.scm
parent6cef1b9b99bffc0eb0479442b52a43209b5a9957 (diff)
downloadguix-44a477e1ac8efe166f3f4d2f56e2ec828a3521e1.tar
guix-44a477e1ac8efe166f3f4d2f56e2ec828a3521e1.tar.gz
gnu: liblxqt: Fix build with Qt 5.5.
* gnu/packages/patches/liblxqt-include.patch: New file. * gnu-system.am (dist_patch_DATA): Register patch. * gnu/packages/lxqt.scm (liblxqt)[source]: Use patch.
Diffstat (limited to 'gnu/packages/lxqt.scm')
-rw-r--r--gnu/packages/lxqt.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index 01cfeae857..e7ed75c77d 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -23,6 +23,7 @@
#:use-module (guix packages)
#:use-module (guix utils)
#:use-module (guix build-system cmake)
+ #:use-module (gnu packages)
#:use-module (gnu packages kde-frameworks)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages qt))
@@ -67,9 +68,11 @@ in Qt.")
(uri
(string-append "https://github.com/lxde/" name "/archive/"
version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz")) (sha256
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
(base32
- "0mbl3qc0yfgfsndqrw8vg8k5irsy0pg2wrad8nwv0aphphd4n7rg"))))
+ "0mbl3qc0yfgfsndqrw8vg8k5irsy0pg2wrad8nwv0aphphd4n7rg"))
+ (patches (map search-patch '("liblxqt-include.patch")))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f))