aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/lua.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-01-03 09:01:53 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-02-08 05:01:42 +0100
commit906f1b48e20a032c22a164c89f9e8862ab2bec7a (patch)
treed77764ffd06090e16bd77473e9636b71ed4c3baa /gnu/packages/lua.scm
parentb2d00af723b900c6db7d6db5c5f5b20e9955840b (diff)
downloadguix-906f1b48e20a032c22a164c89f9e8862ab2bec7a.tar
guix-906f1b48e20a032c22a164c89f9e8862ab2bec7a.tar.gz
gnu: luajit: Update to 2.1.0-beta3.
* gnu/packages/lua.scm (luajit): Update to 2.1.0-beta3. [source]: Remove symlinks patch. * gnu/packages/patches/luajit-symlinks.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/lua.scm')
-rw-r--r--gnu/packages/lua.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/lua.scm b/gnu/packages/lua.scm
index b375ff90c3..fd14956007 100644
--- a/gnu/packages/lua.scm
+++ b/gnu/packages/lua.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2016 doncatnip <gnopap@gmail.com>
;;; Copyright © 2016, 2017 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2016 José Miguel Sánchez García <jmi2k@openmailbox.org>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
;;;
;;; This file is part of GNU Guix.
@@ -116,15 +117,14 @@ for configuration, scripting, and rapid prototyping.")
(define-public luajit
(package
(name "luajit")
- (version "2.1.0-beta2")
+ (version "2.1.0-beta3")
(source (origin
(method url-fetch)
(uri (string-append "http://luajit.org/download/LuaJIT-"
version ".tar.gz"))
(sha256
- (base32 "0iyghj1xjlmd9ywa4flf9yszynf3jhbp0yqb9b49k7ab0g528fbi"))
- (patches (search-patches "luajit-symlinks.patch"
- "luajit-no_ldconfig.patch"))))
+ (base32 "1hyrhpkwjqsv54hnnx4cl8vk44h9d6c9w0fz1jfjz00w255y7lhs"))
+ (patches (search-patches "luajit-no_ldconfig.patch"))))
(build-system gnu-build-system)
(arguments
'(#:tests? #f ;luajit is distributed without tests